# CVE-2026-62673: Grav: .htaccess file extension rules bypass via case variation on case-insensitive filesystems

> Attackers can bypass .htaccess security rules on case-insensitive filesystems to read sensitive configuration files and password hashes.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Aug 2026
- **Updated:** 21 Aug 2026

## What is CVE-2026-62673?

CVE-2026-62673 is a high-severity vulnerability in getgrav grav, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Grav is a file-based Web platform. Prior to 2.0.4, the Grav .htaccess and webserver-configs/htaccess.txt security rules omit the Apache [NC] flag and therefore compare sensitive directory and file-extension patterns case-sensitively. On a case-insensitive filesystem, an unauthenticated requester can use uppercase directory or extension variants to bypass the rules and retrieve files under user/accounts or user/config, including password hashes and security configuration. This issue is fixed in version 2.0.4.

Weakness: CWE-178 (Improper Handling of Case Sensitivity)

## Which versions are affected by CVE-2026-62673?


## How do I fix CVE-2026-62673?

Upgrade to a fixed version.

## Is CVE-2026-62673 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62673 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62673 and fix it if it is affected.

What it is: CVE-2026-62673 is a high-severity vulnerability in getgrav grav, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62673 exists.

Affected product: getgrav grav. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62673/ (Markdown: https://insights.sbomify.com/CVE-2026-62673/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62673
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62673
- OSV: https://osv.dev/vulnerability/CVE-2026-62673

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62673/
Summaries are generated and may contain mistakes; the official description above is the record.
