{"answers":{"affected":"3 open source packages ship an affected version, including omnigent.","exploited":"There is no known exploitation of CVE-2026-62674 in the wild and no public exploit code.","fix":"Upgrade omnigent to 0.3.0 or later.","what":"CVE-2026-62674 is a critical code injection vulnerability in omnigent-ai omnigent, published on 21 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-62674 and fix it if it is affected.\n\nWhat it is: CVE-2026-62674 is a critical code injection vulnerability in omnigent-ai omnigent, published on 21 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-62674 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- omnigent (PyPI): affected all versions; fixed in 0.3.0\n- omnigent (PyPI): affected all versions; fixed in 0.3.0\n- omnigent (PyPI): affected all versions; fixed in 0.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-62674/ (Markdown: https://insights.sbomify.com/CVE-2026-62674/index.md)","id":"CVE-2026-62674","markdown":"https://insights.sbomify.com/CVE-2026-62674/index.md","name":"CVE-2026-62674","record":{"aliases":["GHSA-jrrm-9hc7-2v3h","PYSEC-2026-3874"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"AI agent framework","requires_auth":"low_privilege","summary":"Authenticated users can overwrite shared agent bundles to inject malicious commands, leading to remote code execution on the runner process.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Omnigent is an open-source AI agent framework and meta-harness for orchestrating coding agents. Prior to 0.3.0, PUT /sessions/{session_id}/agent checks LEVEL_EDIT permission for a session but does not reject a bound shared or template agent whose agent.session_id is None. An authenticated user with edit access to a session can replace that shared agent bundle through omnigent/server/routes/sessions.py, add a stdio MCP server, and cause later sessions that use the shared agent to launch an attacker-controlled command through omnigent/tools/mcp.py. The command executes with the Omnigent runner process permissions and can expose files, credentials, workspace data, internal services, and runner availability. This issue is fixed in version 0.3.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Omnigent: Shared Agent Bundle Overwrite Leads to Authenticated Runner RCE","id":"CVE-2026-62674","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"Omnigent: Uploaded Agent Bundle Allows Authenticated Runner RCE via Python Callable Tools","id":"CVE-2026-62675"},"packages":[{"ecosystem":"PyPI","fixed":["0.3.0"],"introduced":["0"],"last_affected":[],"package":"omnigent","purl":null,"source":"GHSA-jrrm-9hc7-2v3h"},{"ecosystem":"PyPI","fixed":["0.3.0"],"introduced":["0"],"last_affected":[],"package":"omnigent","purl":"pkg:pypi/omnigent","source":"GHSA-jrrm-9hc7-2v3h"},{"ecosystem":"PyPI","fixed":["0.3.0"],"introduced":["0"],"last_affected":[],"package":"omnigent","purl":"pkg:pypi/omnigent","source":"PYSEC-2026-3874"}],"prev":{"headline":"Grav: .htaccess file extension rules bypass via case variation on case-insensitive filesystems","id":"CVE-2026-62673"},"products":["omnigent"],"published":"2026-08-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-25","vendors":["omnigent-ai"]},"summary":"Authenticated users can overwrite shared agent bundles to inject malicious commands, leading to remote code execution on the runner process.","url":"https://insights.sbomify.com/CVE-2026-62674/"}