# CVE-2026-62675: Omnigent: Uploaded Agent Bundle Allows Authenticated Runner RCE via Python Callable Tools

> Authenticated users can execute arbitrary commands via malicious agent bundles in Omnigent, leading to remote code execution and data exposure.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Aug 2026
- **Updated:** 21 Aug 2026
- **Also known as:** GHSA-756x-9hf6-q4h4, PYSEC-2026-3872

## What is CVE-2026-62675?

CVE-2026-62675 is a high-severity code injection vulnerability in omnigent-ai omnigent, published on 21 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Omnigent is an open-source AI agent framework and meta-harness for orchestrating coding agents. Prior to 0.3.0, multipart POST /v1/sessions accepts an authenticated user's agent bundle and omnigent/server/bundles.py validate_agent_bundle does not reject a tools..callable dotted Python path. omnigent/runner/tool_dispatch.py _resolve_spec_callable imports the specified module and _execute_spec_callable_tool invokes the resolved function, allowing a bundle to select subprocess.check_output and execute a local command with the runner process permissions. This can expose runner files, environment variables, credentials, workspace data, internal services, and availability without administrator access. This issue is fixed in version 0.3.0.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-62675?

3 open source packages ship an affected version, including omnigent.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `omnigent` | PyPI | All versions | 0.3.0 |
| `omnigent` | PyPI | All versions | 0.3.0 |
| `omnigent` | PyPI | All versions | 0.3.0 |

## How do I fix CVE-2026-62675?

Upgrade omnigent to 0.3.0 or later.

## Is CVE-2026-62675 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62675 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62675 and fix it if it is affected.

What it is: CVE-2026-62675 is a high-severity code injection vulnerability in omnigent-ai omnigent, published on 21 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62675 exists.

Affected packages and fixed versions:
- omnigent (PyPI): affected all versions; fixed in 0.3.0
- omnigent (PyPI): affected all versions; fixed in 0.3.0
- omnigent (PyPI): affected all versions; fixed in 0.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62675/ (Markdown: https://insights.sbomify.com/CVE-2026-62675/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62675
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62675
- OSV: https://osv.dev/vulnerability/CVE-2026-62675

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62675/
Summaries are generated and may contain mistakes; the official description above is the record.
