# CVE-2026-62676: Omnigent Guardrail policy bypass: shell-command parser fails open in policies/builtins/_shell.py

> An attacker can bypass shell command security policies to push code to unauthorized repositories or escape workspace confinement in the Omnigent AI agent framework.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Aug 2026
- **Updated:** 26 Aug 2026
- **Also known as:** GHSA-7mqg-cx4g-x2rf, PYSEC-2026-3873

## What is CVE-2026-62676?

CVE-2026-62676 is a high-severity vulnerability in omnigent-ai omnigent, published on 21 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Omnigent is an open-source AI agent framework and meta-harness for orchestrating coding agents. Prior to 0.3.0, the shared shell-command parser in omnigent/policies/builtins/_shell.py fails to recognize combined interpreter flags, the timeout, nice, setsid, and stdbuf wrappers, command substitutions, and a single background control operator. A gated git push or gh write hidden with these forms produces no parsed operation, causing the github.py write_repos and write_branches allowlist and the working_dir.py workspace confinement policies to abstain and allow the command. An authenticated or prompt-injected agent can therefore push to an unauthorized repository or branch or escape the intended workspace. This issue is fixed in version 0.3.0.

Weakness: CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2026-62676?

3 open source packages ship an affected version, including omnigent.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `omnigent` | PyPI | All versions | 0.3.0 |
| `omnigent` | PyPI | All versions | 0.3.0 |
| `omnigent` | PyPI | All versions | 0.3.0 |

## How do I fix CVE-2026-62676?

Upgrade omnigent to 0.3.0 or later.

## Is CVE-2026-62676 being exploited?

There is no known exploitation of CVE-2026-62676 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62676 and fix it if it is affected.

What it is: CVE-2026-62676 is a high-severity vulnerability in omnigent-ai omnigent, published on 21 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-62676 in the wild and no public exploit code.

Affected packages and fixed versions:
- omnigent (PyPI): affected all versions; fixed in 0.3.0
- omnigent (PyPI): affected all versions; fixed in 0.3.0
- omnigent (PyPI): affected all versions; fixed in 0.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62676/ (Markdown: https://insights.sbomify.com/CVE-2026-62676/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62676
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62676
- OSV: https://osv.dev/vulnerability/CVE-2026-62676

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62676/
Summaries are generated and may contain mistakes; the official description above is the record.
