# CVE-2026-62680: Orval: Generation-time SSRF + remote/local file inclusion via unrestricted $ref

> Attackers can trigger SSRF and file inclusion in Orval by providing malicious OpenAPI specs, potentially exposing internal services or local files during client generation.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** GHSA-cxq5-97v7-87j8, ROOT-APP-NPM-CVE-2026-62680

## What is CVE-2026-62680?

CVE-2026-62680 is a high-severity server-side request forgery vulnerability in orval-labs orval, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Orval generates type-safe JavaScript clients in TypeScript from OpenAPI v3 and Swagger v2 specifications. Prior to 8.22.0, Orval resolves remote and local external $ref values without an allowlist or confinement to the input directory. Processing an attacker-controlled OpenAPI description can cause requests from the developer or CI host to attacker-selected or internal HTTP services, read absolute or out-of-tree local files, and inline untrusted remote schemas into generated clients. The affected code is packages/orval/src/import-specs.ts external reference loading. This issue is fixed in version 8.22.0.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-829 (Inclusion of Functionality from Untrusted Control Sphere), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-62680?

2 open source packages ship an affected version, including orval.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `orval` | npm | All versions | 8.22.0 |
| `orval` | npm | All versions | 8.22.0 |

## How do I fix CVE-2026-62680?

Upgrade orval to 8.22.0 or later.

## Is CVE-2026-62680 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62680 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62680 and fix it if it is affected.

What it is: CVE-2026-62680 is a high-severity server-side request forgery vulnerability in orval-labs orval, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62680 exists.

Affected packages and fixed versions:
- orval (npm): affected all versions; fixed in 8.22.0
- orval (npm): affected all versions; fixed in 8.22.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62680/ (Markdown: https://insights.sbomify.com/CVE-2026-62680/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62680
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62680
- OSV: https://osv.dev/vulnerability/CVE-2026-62680

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62680/
Summaries are generated and may contain mistakes; the official description above is the record.
