CVE-2026-6270 @fastify/middie vulnerable to middleware authentication bypass in child plugin scopes

Critical 9.1 Published Updated

Attackers can bypass authentication in child plugin scopes by exploiting middleware inheritance flaws in @fastify/middie.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-6270?

CVE-2026-6270 is a critical authentication bypass vulnerability in @fastify/middie, published on 16 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

@fastify/middie versions 9.3.1 and earlier do not register inherited middleware directly on child plugin engine instances. When a Fastify application registers authentication middleware in a parent scope and then registers child plugins with @fastify/middie, the child scope does not inherit the parent middleware. This allows unauthenticated requests to reach routes defined in child plugin scopes, bypassing authentication and authorization checks. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds.

Weakness: CWE-436

Which versions are affected by CVE-2026-6270?

2 open source packages ship an affected version, including @fastify/middie. It affects 1 product.

PackageAffectedFixed in
@fastify/middie npmAll versions9.3.2
@fastify/middie npmAll versions9.3.2

Products include Fastify Fastify\/Middie.

How do I fix CVE-2026-6270?

Upgrade @fastify/middie to 9.3.2 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-6270 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-6270 exists.

Sources

Also known as CLSA-2026-1778201074, GHSA-72c6-fx6q-fr5w.

Is CVE-2026-6270 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free