{"answers":{"affected":"2 open source packages ship an affected version, including @fastify/middie. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-6270 exists.","fix":"Upgrade @fastify/middie to 9.3.2 or later.","what":"CVE-2026-6270 is a critical authentication bypass vulnerability in @fastify/middie, published on 16 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-6270 and fix it if it is affected.\n\nWhat it is: CVE-2026-6270 is a critical authentication bypass vulnerability in @fastify/middie, published on 16 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-6270 exists.\n\nAffected packages and fixed versions:\n- @fastify/middie (npm): affected all versions; fixed in 9.3.2\n- @fastify/middie (npm): affected all versions; fixed in 9.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-6270/ (Markdown: https://insights.sbomify.com/CVE-2026-6270/index.md)","id":"CVE-2026-6270","markdown":"https://insights.sbomify.com/CVE-2026-6270/index.md","name":"CVE-2026-6270","record":{"aliases":["CLSA-2026-1778201074","GHSA-72c6-fx6q-fr5w"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Fastify middleware library","requires_auth":"none","summary":"Attackers can bypass authentication in child plugin scopes by exploiting middleware inheritance flaws in @fastify/middie.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"openjs","cpe":[{"product":"fastify\\/middie","vendor":"fastify"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-436","name":"Interpretation Conflict"}],"description":"@fastify/middie versions 9.3.1 and earlier do not register inherited middleware directly on child plugin engine instances. When a Fastify application registers authentication middleware in a parent scope and then registers child plugins with @fastify/middie, the child scope does not inherit the parent middleware. This allows unauthenticated requests to reach routes defined in child plugin scopes, bypassing authentication and authorization checks. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"@fastify/middie vulnerable to middleware authentication bypass in child plugin scopes","id":"CVE-2026-6270","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Career Section \u003c= 1.7 - Unauthenticated Arbitrary File Upload","id":"CVE-2026-6271"},"packages":[{"ecosystem":"npm","fixed":["9.3.2"],"introduced":["0"],"last_affected":[],"package":"@fastify/middie","purl":null,"source":"GHSA-72c6-fx6q-fr5w"},{"ecosystem":"npm","fixed":["9.3.2"],"introduced":["0"],"last_affected":[],"package":"@fastify/middie","purl":"pkg:npm/%40fastify/middie","source":"GHSA-72c6-fx6q-fr5w"}],"prev":{"headline":"Incorrect Authorization in GitLab","id":"CVE-2026-6269"},"products":["@fastify/middie"],"published":"2026-04-16","related":[{"cvss_score":9.1,"headline":"@fastify/middie vulnerable to path-scoped middleware bypass via absolute-form request target","id":"CVE-2026-85184","kev_date_added":null,"published":"2026-09-04"},{"cvss_score":9.1,"headline":"@fastify/middie vulnerable to authorization bypass via encoded slash in path parameter values","id":"CVE-2026-14198","kev_date_added":null,"published":"2026-07-01"},{"cvss_score":8.4,"headline":"Fastify Middie Middleware Path Bypass","id":"CVE-2026-22031","kev_date_added":null,"published":"2026-01-19"},{"cvss_score":8.2,"headline":"@fastify/middie has an improper path normalization vulnerability","id":"CVE-2026-2880","kev_date_added":null,"published":"2026-02-27"},{"cvss_score":7.5,"headline":"@fastify/middie standalone engine vulnerable to Denial of Service via malformed percent-encoded paths","id":"CVE-2026-14181","kev_date_added":null,"published":"2026-07-01"},{"cvss_score":7.4,"headline":"@fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option","id":"CVE-2026-33804","kev_date_added":null,"published":"2026-04-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-16","vendors":["@fastify/middie"]},"summary":"Attackers can bypass authentication in child plugin scopes by exploiting middleware inheritance flaws in @fastify/middie.","url":"https://insights.sbomify.com/CVE-2026-6270/"}