# CVE-2026-62858: YOURLS: Unauthenticated File Inclusion

> Unauthenticated attackers can traverse directories to include and execute local PHP files, leading to remote code execution.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2026
- **Updated:** 14 Oct 2026
- **Also known as:** GHSA-f8ff-652m-j5rx

## What is CVE-2026-62858?

CVE-2026-62858 is a medium-severity path traversal vulnerability in YOURLS, published on 14 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

YOURLS is a self-hosted, customizable URL shortener written in PHP. Prior to 1.10.5, yourls_get_request() extracted the request path without sanitization, after which yourls_sanitize_url() and yourls_esc_url() preserved dot and slash traversal sequences before an attacker-controlled keyword reached file_exists() and include() under YOURLS_PAGEDIR. An unauthenticated remote attacker could traverse outside the intended pages directory and include a local PHP file that was already present on the server, such as an uploaded or injected file, causing the file to execute in the YOURLS web process. This issue is fixed in version 1.10.5.

Weakness: CWE-98 (Improper Control of Filename for Include/Require Statement in PHP Program)

## Which versions are affected by CVE-2026-62858?

2 open source packages ship an affected version, including yourls/yourls.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yourls/yourls` | Packagist | All versions | 1.10.5 |
| `yourls/yourls` | Packagist | All versions | 1.10.5 |

## How do I fix CVE-2026-62858?

Upgrade yourls/yourls to 1.10.5 or later.

## Is CVE-2026-62858 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62858 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62858 and fix it if it is affected.

What it is: CVE-2026-62858 is a medium-severity path traversal vulnerability in YOURLS, published on 14 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62858 exists.

Affected packages and fixed versions:
- yourls/yourls (Packagist): affected all versions; fixed in 1.10.5
- yourls/yourls (Packagist): affected all versions; fixed in 1.10.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62858/ (Markdown: https://insights.sbomify.com/CVE-2026-62858/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62858
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62858
- OSV: https://osv.dev/vulnerability/CVE-2026-62858

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62858/
Summaries are generated and may contain mistakes; the official description above is the record.
