# CVE-2026-62960: Git for Windows: Server-advertised bundle-uri can trigger outbound SMB callbacks via UNC and file:// paths on Windows

> A malicious Git server can trigger outbound SMB connections via bundle URIs, exposing NTLM credentials to attackers when bundle URI transfer is enabled.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Aug 2026
- **Updated:** 26 Aug 2026
- **Also known as:** GHSA-xrpg-8j9v-v282, MINI-2wc5-wj78-pcr4, OESA-2026-3622, OESA-2026-3623, OESA-2026-3733

## What is CVE-2026-62960?

CVE-2026-62960 is a high-severity server-side request forgery vulnerability in git-for-windows git, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Git for Windows is the Windows port of Git. Prior to 2.55.0.windows.4, a malicious remote Git server can advertise a bundle URI that reaches transport_get_remote_bundle_uri(), fetch_bundle_uri_internal(), and copy_uri_to_file() in bundle-uri.c during clone or fetch when transfer.bundleuri=true. Non-HTTP(S) values are treated as local filesystem paths, and file URI prefixes are removed, so a bare UNC path or file URI targeting an attacker-controlled share causes Windows to initiate an outbound SMB connection. This can expose NTLM authentication material to the attacker-selected host. This issue is fixed in version 2.55.0.windows.4.

Weakness: CWE-610 (Externally Controlled Reference to a Resource in Another Sphere), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-62960?


## How do I fix CVE-2026-62960?

Upgrade to a fixed version.

## Is CVE-2026-62960 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62960 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62960 and fix it if it is affected.

What it is: CVE-2026-62960 is a high-severity server-side request forgery vulnerability in git-for-windows git, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62960 exists.

Affected product: git-for-windows git. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62960/ (Markdown: https://insights.sbomify.com/CVE-2026-62960/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62960
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62960
- OSV: https://osv.dev/vulnerability/CVE-2026-62960

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62960/
Summaries are generated and may contain mistakes; the official description above is the record.
