# CVE-2026-62982: Glances: Incomplete fix of CVE-2026-32608: action-template sanitizer is bypassed by nested stat values (process 'cmdline') → OS command injection

> Attackers can execute OS commands via bypassed sanitization in administrator-configured action templates, requiring admin setup.

- **Severity:** High 8.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Aug 2026
- **Updated:** 17 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-62982, GHSA-73wf-9vmv-5pv9, PYSEC-2026-3666, UBUNTU-CVE-2026-62982

## What is CVE-2026-62982?

CVE-2026-62982 is a high-severity command injection vulnerability in nicolargo glances, published on 17 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Glances is an open-source system cross-platform monitoring tool. From 4.5.2 until 4.5.6, _sanitize_mustache_dict() in glances/actions.py skips nested list and dictionary strings such as process cmdline values, allowing pipe characters to survive chevron.render() and be executed by secure_popen() through administrator-configured action templates. This issue is fixed in 4.5.6.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-62982?

3 open source packages ship an affected version, including glances.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `glances` | PyPI | From 4.5.2 | 4.5.6 |
| `glances` | PyPI | From 4.5.2 | 4.5.6 |
| `glances` | PyPI | From 4.5.2 | 4.5.6 |

## How do I fix CVE-2026-62982?

Upgrade glances to 4.5.6 or later.

## Is CVE-2026-62982 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62982 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62982 and fix it if it is affected.

What it is: CVE-2026-62982 is a high-severity command injection vulnerability in nicolargo glances, published on 17 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62982 exists.

Affected packages and fixed versions:
- glances (PyPI): affected from 4.5.2; fixed in 4.5.6
- glances (PyPI): affected from 4.5.2; fixed in 4.5.6
- glances (PyPI): affected from 4.5.2; fixed in 4.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62982/ (Markdown: https://insights.sbomify.com/CVE-2026-62982/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62982
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62982
- OSV: https://osv.dev/vulnerability/CVE-2026-62982

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62982/
Summaries are generated and may contain mistakes; the official description above is the record.
