# CVE-2026-62993: Smarty: SSRF via redirect bypass of trusted_uri using {fetch}

> Attackers can bypass trusted URI restrictions in Smarty's fetch function via open redirects, enabling server-side request forgery to access internal resources.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Aug 2026
- **Updated:** 2 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-62993, GHSA-cq55-c7wv-pxmq, UBUNTU-CVE-2026-62993

## What is CVE-2026-62993?

CVE-2026-62993 is a medium-severity server-side request forgery vulnerability in smarty-php smarty, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to 4.5.7 and 5.8.2, depending on the release line, Smarty's {fetch} handling in libs/plugins/function.fetch.php and src/FunctionHandler/Fetch.php used Security::isTrustedUri() to validate only the initial remote URL against trusted_uri when a security policy was active. For resources handled by file_get_contents(), including HTTPS URLs, PHP followed HTTP redirects by default. An attacker who could supply or influence a fetch target and had an open redirect on a trusted host could redirect the request to an attacker-chosen internal endpoint, bypass the trusted_uri allowlist, and perform server-side request forgery. This issue is fixed in versions 4.5.7 and 5.8.2.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-62993?

4 open source packages ship an affected version, including smarty/smarty.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `smarty/smarty` | Packagist | All versions | 4.5.7 |
| `smarty/smarty` | Packagist | All versions | 4.5.7 |
| `smarty/smarty` | Packagist | From 5.0.0 | 5.8.2 |
| `smarty/smarty` | Packagist | From 5.0.0 | 5.8.2 |

## How do I fix CVE-2026-62993?

Upgrade smarty/smarty to a fixed version for your release line: 4.5.7 or 5.8.2.

## Is CVE-2026-62993 being exploited?

There is no known exploitation of CVE-2026-62993 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62993 and fix it if it is affected.

What it is: CVE-2026-62993 is a medium-severity server-side request forgery vulnerability in smarty-php smarty, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-62993 in the wild and no public exploit code.

Affected packages and fixed versions:
- smarty/smarty (Packagist): affected all versions; fixed in 4.5.7
- smarty/smarty (Packagist): affected all versions; fixed in 4.5.7
- smarty/smarty (Packagist): affected from 5.0.0; fixed in 5.8.2
- smarty/smarty (Packagist): affected from 5.0.0; fixed in 5.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62993/ (Markdown: https://insights.sbomify.com/CVE-2026-62993/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62993
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62993
- OSV: https://osv.dev/vulnerability/CVE-2026-62993

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62993/
Summaries are generated and may contain mistakes; the official description above is the record.
