# CVE-2026-62994: CoreDNS `k8s_external` headless AXFR can emit an empty transfer batch that panics the `transfer` plugin

> A remote attacker can crash CoreDNS by requesting AXFR for a specific headless service configuration, causing a denial of service.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jul 2026
- **Updated:** 17 Jul 2026
- **Also known as:** AZL-92895, ECHO-0581-5ceb-411c, GHSA-74w3-63xv-x9mv, GO-2026-6805, MINI-4mc2-x74h-q8hr, MINI-7299-hjwp-xc7r, MINI-7gwm-6qhx-p9fh, MINI-8mrx-cwqx-p3hc, MINI-c9qh-mqp6-46cx, MINI-cv2h-6v56-rhmf, MINI-fxr6-76p7-xw24, MINI-g4rq-88p9-qg4c, MINI-h6qx-cxhh-mr4j, MINI-m436-q9f3-fjr2, MINI-mv73-r677-wfvq, MINI-mw7f-274h-gcq2, MINI-p4r2-cc34-m3qw, MINI-q679-9j9h-qv7x, MINI-rp5v-68wx-928f, MINI-rq22-j9hc-249r, MINI-rvc7-7552-9p78, MINI-vx6m-2r2j-xrr4, MINI-wf4q-672x-46gh

## What is CVE-2026-62994?

CVE-2026-62994 is a low-severity denial of service vulnerability in coredns, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CoreDNS is a DNS server written in Go. From 1.9.4 until 1.14.5, a network DNS client allowed to request AXFR for a CoreDNS zone can trigger a panic when CoreDNS is configured with k8s_external headless-service zone transfers and Kubernetes contains a headless service endpoint with no declared ports; plugin/kubernetes/object/endpoint.go creates Port: -1, plugin/k8s_external/msg_to_dns.go skips that service, plugin/k8s_external/transfer.go sends an empty []dns.RR batch, and plugin/transfer/transfer.go indexes records[0] without checking the batch is non-empty. This issue is fixed in version 1.14.5.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions), CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-62994?

3 open source packages ship an affected version, including github.com/coredns/coredns. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/coredns/coredns` | Go | From 1.9.4 | 1.14.5 |
| `github.com/coredns/coredns` | Go | From 1.9.4 | 1.14.5 |
| `github.com/coredns/coredns` | Go | From 1.9.4 | 1.14.5 |

Products: Coredns.io Coredns.

## How do I fix CVE-2026-62994?

Upgrade github.com/coredns/coredns to 1.14.5 or later.

## Is CVE-2026-62994 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62994 exists.

## Other vulnerabilities in coredns

- [CVE-2026-32934](https://insights.sbomify.com/CVE-2026-32934/): CoreDNS DNS-over-QUIC unbounded goroutine growth leads to denial of service (high 8.7)
- [CVE-2026-32936](https://insights.sbomify.com/CVE-2026-32936/): CoreDNS DoH GET path missing size validation causes CPU and memory amplification (high 8.7)
- [CVE-2026-33190](https://insights.sbomify.com/CVE-2026-33190/): CoreDNS TSIG authentication bypass on encrypted DNS transports (high 8.7)
- [CVE-2026-33489](https://insights.sbomify.com/CVE-2026-33489/): CoreDNS transfer plugin subzone ACL bypass via lexicographic zone comparison (high 8.2)
- [CVE-2026-35579](https://insights.sbomify.com/CVE-2026-35579/): CoreDNS TSIG authentication bypass on gRPC, QUIC, DoH, and DoH3 transports (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62994 and fix it if it is affected.

What it is: CVE-2026-62994 is a low-severity denial of service vulnerability in coredns, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62994 exists.

Affected packages and fixed versions:
- github.com/coredns/coredns (Go): affected from 1.9.4; fixed in 1.14.5
- github.com/coredns/coredns (Go): affected from 1.9.4; fixed in 1.14.5
- github.com/coredns/coredns (Go): affected from 1.9.4; fixed in 1.14.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62994/ (Markdown: https://insights.sbomify.com/CVE-2026-62994/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62994
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62994
- OSV: https://osv.dev/vulnerability/CVE-2026-62994

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62994/
Summaries are generated and may contain mistakes; the official description above is the record.
