# CVE-2026-62996: Smarty Security stream restriction bypass through stream: resource

> An attacker can read arbitrary local files by exploiting insufficient stream wrapper restrictions in the Smarty PHP template engine.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2026
- **Updated:** 7 Aug 2026
- **Also known as:** GHSA-rjhh-76wf-8xmw, UBUNTU-CVE-2026-62996

## What is CVE-2026-62996?

CVE-2026-62996 is a medium-severity path traversal vulnerability in smarty-php smarty, published on 7 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. From 5.0.0 until 5.8.4, Smarty's stream: resource-name handling does not adequately restrict which PHP stream wrappers and filter chains can be referenced from a template, allowing a php://filter-wrapped resource name to be used to read the contents of arbitrary local files accessible to the PHP process. An attacker able to author or influence a template's resource reference could exploit this to disclose sensitive file contents outside the intended template/config scope. This issue is fixed in version 5.8.4.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-62996?

2 open source packages ship an affected version, including smarty/smarty.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `smarty/smarty` | Packagist | From 5.0.0 | 5.8.4 |
| `smarty/smarty` | Packagist | From 5.0.0 | 5.8.4 |

## How do I fix CVE-2026-62996?

Upgrade smarty/smarty to 5.8.4 or later.

## Is CVE-2026-62996 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62996 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62996 and fix it if it is affected.

What it is: CVE-2026-62996 is a medium-severity path traversal vulnerability in smarty-php smarty, published on 7 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62996 exists.

Affected packages and fixed versions:
- smarty/smarty (Packagist): affected from 5.0.0; fixed in 5.8.4
- smarty/smarty (Packagist): affected from 5.0.0; fixed in 5.8.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62996/ (Markdown: https://insights.sbomify.com/CVE-2026-62996/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62996
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62996
- OSV: https://osv.dev/vulnerability/CVE-2026-62996

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62996/
Summaries are generated and may contain mistakes; the official description above is the record.
