# CVE-2026-62997: Kedro-Datasets: Remote code execution in experimental `PyTorchDataset` via unsafe `torch.load`

> Attackers can execute arbitrary code via malicious PyTorch model files in the experimental Kedro-Datasets component if users load untrusted data.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 16 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-f9q4-h45w-jrrq

## What is CVE-2026-62997?

CVE-2026-62997 is a high-severity unsafe deserialization vulnerability in kedro-org kedro-plugins, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Kedro-Datasets provides data connectors for Kedro. From version 5.0.0 until 9.5.0, kedro_datasets_experimental.pytorch.PyTorchDataset in kedro-datasets loads .pt model files with torch.load without enforcing weights_only=True, and user-supplied load_args are silently dropped. On PyTorch versions earlier than 2.6, a malicious pickle-backed model from an attacker-influenced shared registry, downloaded checkpoint, or partitioned external source can execute arbitrary code when a Kedro pipeline loads it. The issue affects only the opt-in kedro_datasets_experimental component and does not affect users who load only trusted files. This issue is fixed in version 9.5.0.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-62997?


## How do I fix CVE-2026-62997?

No fix has been published for CVE-2026-62997 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-62997 being exploited?

There is no known exploitation of CVE-2026-62997 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62997 and fix it if it is affected.

What it is: CVE-2026-62997 is a high-severity unsafe deserialization vulnerability in kedro-org kedro-plugins, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-62997 in the wild and no public exploit code.

Affected product: kedro-org kedro-plugins. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62997/ (Markdown: https://insights.sbomify.com/CVE-2026-62997/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62997
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62997
- OSV: https://osv.dev/vulnerability/CVE-2026-62997

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62997/
Summaries are generated and may contain mistakes; the official description above is the record.
