CVE-2026-63004 Unleash: Addon webhook URL is dialed server-side with no internal-address filtering, enabling SSRF to internal services / cloud metadata and exfiltration of configured request headers
Authenticated attackers can exploit Unleash addon webhooks to perform Server-Side Request Forgery, accessing internal services and leaking sensitive headers.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-63004?
CVE-2026-63004 is a medium-severity server-side request forgery vulnerability in unleash, published on 21 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Unleash is an open-source feature management platform. Prior to 7.5.2, 7.6.5, and 8.0.2, the addon and integration subsystem passes the operator-controlled parameters.url value from src/lib/addons/webhook.ts and the Slack, Microsoft Teams, Datadog, and New Relic integrations to Addon.fetchRetry in src/lib/addons/addon.ts without restricting loopback, link-local, private, or cloud metadata addresses. An authenticated actor with the root CREATE_ADDON or UPDATE_ADDON permission can cause the server to send requests from inside its network boundary, use integration event status as a blind probing oracle, forward Authorization, customHeaders, or DD-API-KEY values to an attacker-observed host, and deliver the feature-event JSON body to internal services. This issue is fixed in versions 7.5.2, 7.6.5, and 8.0.2.
Weakness: CWE-918
Which versions are affected by CVE-2026-63004?
6 open source packages ship an affected version, including unleash-server.
| Package | Affected | Fixed in |
|---|---|---|
unleash-server npm | All versions | 7.5.2 |
unleash-server npm | All versions | 7.5.2 |
unleash-server npm | From 7.6.0 | 7.6.5 |
unleash-server npm | From 7.6.0 | 7.6.5 |
unleash-server npm | From 8.0.0 | 8.0.2 |
unleash-server npm | From 8.0.0 | 8.0.2 |
How do I fix CVE-2026-63004?
Upgrade unleash-server to a fixed version for your release line: 7.5.2, 7.6.5 or 8.0.2.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-63004 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63004 exists.
Sources
Also known as GHSA-5vf6-jrqr-78fj, MINI-hp2x-w8fx-vw7p.