# CVE-2026-63004: Unleash: Addon webhook URL is dialed server-side with no internal-address filtering, enabling SSRF to internal services / cloud metadata and exfiltration of configured request headers

> Authenticated attackers can exploit Unleash addon webhooks to perform Server-Side Request Forgery, accessing internal services and leaking sensitive headers.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Aug 2026
- **Updated:** 21 Aug 2026
- **Also known as:** GHSA-5vf6-jrqr-78fj, MINI-hp2x-w8fx-vw7p

## What is CVE-2026-63004?

CVE-2026-63004 is a medium-severity server-side request forgery vulnerability in unleash, published on 21 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Unleash is an open-source feature management platform. Prior to 7.5.2, 7.6.5, and 8.0.2, the addon and integration subsystem passes the operator-controlled parameters.url value from src/lib/addons/webhook.ts and the Slack, Microsoft Teams, Datadog, and New Relic integrations to Addon.fetchRetry in src/lib/addons/addon.ts without restricting loopback, link-local, private, or cloud metadata addresses. An authenticated actor with the root CREATE_ADDON or UPDATE_ADDON permission can cause the server to send requests from inside its network boundary, use integration event status as a blind probing oracle, forward Authorization, customHeaders, or DD-API-KEY values to an attacker-observed host, and deliver the feature-event JSON body to internal services. This issue is fixed in versions 7.5.2, 7.6.5, and 8.0.2.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-63004?

6 open source packages ship an affected version, including unleash-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `unleash-server` | npm | All versions | 7.5.2 |
| `unleash-server` | npm | All versions | 7.5.2 |
| `unleash-server` | npm | From 7.6.0 | 7.6.5 |
| `unleash-server` | npm | From 7.6.0 | 7.6.5 |
| `unleash-server` | npm | From 8.0.0 | 8.0.2 |
| `unleash-server` | npm | From 8.0.0 | 8.0.2 |

## How do I fix CVE-2026-63004?

Upgrade unleash-server to a fixed version for your release line: 7.5.2, 7.6.5 or 8.0.2.

## Is CVE-2026-63004 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63004 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63004 and fix it if it is affected.

What it is: CVE-2026-63004 is a medium-severity server-side request forgery vulnerability in unleash, published on 21 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63004 exists.

Affected packages and fixed versions:
- unleash-server (npm): affected all versions; fixed in 7.5.2
- unleash-server (npm): affected all versions; fixed in 7.5.2
- unleash-server (npm): affected from 7.6.0; fixed in 7.6.5
- unleash-server (npm): affected from 7.6.0; fixed in 7.6.5
- unleash-server (npm): affected from 8.0.0; fixed in 8.0.2
- unleash-server (npm): affected from 8.0.0; fixed in 8.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63004/ (Markdown: https://insights.sbomify.com/CVE-2026-63004/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63004
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63004
- OSV: https://osv.dev/vulnerability/CVE-2026-63004

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63004/
Summaries are generated and may contain mistakes; the official description above is the record.
