CVE-2026-63016 Apache InLong: Ordinary users can create new packages

Medium 5.3 Published Updated

Ordinary users can create new packages, potentially affecting operational configuration or allowing non-official package uploads.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-63016?

CVE-2026-63016 is a medium-severity missing authorization vulnerability in Apache InLong, published on 20 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Uncontrolled Resource Consumption vulnerability in Apache InLong. Users could affect operational configuration or allow upload of non-official packages.

This issue affects Apache InLong: from 2.0.0 before 2.4.0.

Users are advised to upgrade to Apache InLong's 2.4.0 or cherry-pick [1] to solve it.

[1]

https://github.com/apache/inlong/pull/12095 https://github.com/apache/inlong/pull/11732

Weakness: CWE-400

Which versions are affected by CVE-2026-63016?

It affects 1 product.

Products include Apache Inlong.

How do I fix CVE-2026-63016?

No fix has been published for CVE-2026-63016 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-63016 being exploited?

There is no known exploitation of CVE-2026-63016 in the wild and no public exploit code.

Sources

Also known as GHSA-pr7c-fhx7-xrq6.

Is CVE-2026-63016 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free