# CVE-2026-63030: WordPress Core Interpretation Conflict

> Attackers can exploit REST API route confusion and SQL injection to achieve remote code execution on WordPress installations.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 21 Jul 2026 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2026
- **Updated:** 7 Oct 2026
- **Also known as:** BIT-wordpress-2026-63030, BIT-wordpress-multisite-2026-63030, DEBIAN-CVE-2026-63030, MINI-3225-xjqh-8h8q, MINI-9p9r-7ppc-qj84, UBUNTU-CVE-2026-63030

## What is CVE-2026-63030?

CVE-2026-63030 is a critical SQL injection vulnerability in Wordpress Wordpress, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

WordPress 6.9.x before 6.9.5 and 7.0.x before 7.0.2 is affected by a REST API batch endpoint route confusion issue which, combined with the author__not_in WP_Query SQL Injection (CVE-2026-60137), could allow an attacker to perform SQL Injection and achieve Remote Code Execution.

Weakness: CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2026-63030?

2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wordpress` | Bitnami | From 6.9.0 | 6.9.5, 7.0.2 |
| `wordpress-multisite` | Bitnami | From 6.9.0 | 6.9.5, 7.0.2 |

Products: Wordpress Wordpress.

## How do I fix CVE-2026-63030?

Upgrade wordpress to a fixed version for your release line: 6.9.5 or 7.0.2. US federal agencies must fix it by 24 Jul 2026.

## Is CVE-2026-63030 being exploited?

Yes. Attackers have exploited CVE-2026-63030 in the wild since at least 21 Jul 2026.

Public exploit code:

- wp2shell (CVE-2026-63030 & CVE-2026-60137) - full RCE chain (github_poc): https://github.com/Icex0/wp2shell-poc
- CVE-2026-63030 + CVE-2026-60137 - “wp2shell”: unauthenticated RCE in WordPress core (github_poc): https://github.com/0xsha/wp2shell
- CVE-2026-63030, CVE-2026-60137, wp2shell scanner (github_poc): https://github.com/ZephrFish/wp2shell-scanner
- Non-destructive detector + Docker lab for wp2shell (CVE-2026-63030 REST /batch/v1 route confusion + CVE-2026-60137 author__not_in SQLi) in WordPress core 6.9.0-6.9.4 / 7.0.0-7.0.1 (github_poc): https://github.com/dinosn/wp2shell-lab
- Pre-auth RCE PoC for CVE-2026-63030 / CVE-2026-60137 (WordPress core) (github_poc): https://github.com/securelayer7/WordPresShell
- WP2Shell - CVE-2026-63030 / CVE-2026-60137 This tool exploits a critical SQL injection vulnerability in the WordPress REST API `/wp-json/batch/v1` endpoint, allowing unauthenticated attackers to execute arbitrary SQL queries and achieve Remote Code Execution (RCE) on vulnerable WordPress installations. (github_poc): https://github.com/NULL200OK/WP2Shell

## Other vulnerabilities in Wordpress Wordpress

- [CVE-2026-87902](https://insights.sbomify.com/CVE-2026-87902/): WordPress Core Remote File Inclusion (high 8.1, exploited in the wild)
- [CVE-2026-60137](https://insights.sbomify.com/CVE-2026-60137/): WordPress Core SQL Injection (medium 5.9, exploited in the wild)
- [CVE-2012-2399](https://insights.sbomify.com/CVE-2012-2399/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2012-2400](https://insights.sbomify.com/CVE-2012-2400/): Other in n/a (critical 10.0)
- [CVE-2011-3122](https://insights.sbomify.com/CVE-2011-3122/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63030 and fix it if it is affected.

What it is: CVE-2026-63030 is a critical SQL injection vulnerability in Wordpress Wordpress, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2026-63030 in the wild since at least 21 Jul 2026.

Affected packages and fixed versions:
- wordpress (Bitnami): affected from 6.9.0; fixed in 6.9.5, 7.0.2
- wordpress-multisite (Bitnami): affected from 6.9.0; fixed in 6.9.5, 7.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63030/ (Markdown: https://insights.sbomify.com/CVE-2026-63030/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63030
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63030
- OSV: https://osv.dev/vulnerability/CVE-2026-63030

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63030/
Summaries are generated and may contain mistakes; the official description above is the record.
