# CVE-2026-63116: deepstream: PATCH_MULTI action bypasses Valve permission system allowing unauthorized record writes

> Authenticated users can bypass permission checks to modify arbitrary protected records in deepstream.io when using the config permission type.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Sep 2026
- **Updated:** 21 Sep 2026
- **Also known as:** GHSA-89vx-jh4q-vg3w

## What is CVE-2026-63116?

CVE-2026-63116 is a high-severity missing authorization vulnerability in deepstreamIO deepstream.io, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

deepstream is a server that allows clients and backend services to sync data, send messages and make rpcs at scale. From 10.1.0 until 10.1.1, src/services/permission/valve/rules-map.ts omits RECORD_ACTION.PATCH_MULTI from RULES_MAP. When an authenticated user sends a PATCH_MULTI record operation while permission.type is config, getRulesForMessage returns a null rule specification and ConfigPermission.canPerformAction treats the missing specification as an unconditional allow instead of applying RULE_TYPES.WRITE. Any authenticated user can therefore modify arbitrary protected records, corrupt application state, or cause service disruption; deployments using the default permission type none already allow all operations and are not additionally affected. This issue is fixed in version 10.1.1.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-63116?

2 open source packages ship an affected version, including @deepstream/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@deepstream/server` | npm | From 10.1.0 | 10.1.1 |
| `@deepstream/server` | npm | From 10.1.0 | 10.1.1 |

## How do I fix CVE-2026-63116?

Upgrade @deepstream/server to 10.1.1 or later.

## Is CVE-2026-63116 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63116 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63116 and fix it if it is affected.

What it is: CVE-2026-63116 is a high-severity missing authorization vulnerability in deepstreamIO deepstream.io, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63116 exists.

Affected packages and fixed versions:
- @deepstream/server (npm): affected from 10.1.0; fixed in 10.1.1
- @deepstream/server (npm): affected from 10.1.0; fixed in 10.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63116/ (Markdown: https://insights.sbomify.com/CVE-2026-63116/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63116
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63116
- OSV: https://osv.dev/vulnerability/CVE-2026-63116

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63116/
Summaries are generated and may contain mistakes; the official description above is the record.
