# CVE-2026-63119: MCP Ruby SDK: Unbounded line buffer in stdio transports leads to memory exhaustion (DoS)

> A malicious peer can exhaust process memory in the MCP Ruby SDK by sending data without newlines, causing a denial of service.

- **Severity:** Medium 6.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jul 2026
- **Updated:** 29 Jul 2026
- **Also known as:** GHSA-7683-3w9x-ch42

## What is CVE-2026-63119?

CVE-2026-63119 is a medium-severity denial of service vulnerability in modelcontextprotocol ruby-sdk, published on 29 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

MCP Ruby SDK is the official Ruby SDK for Model Context Protocol servers and clients. Prior to 0.23.0, MCP::Server::Transports::StdioTransport and MCP::Client::Stdio in the mcp gem use IO#gets without a byte limit, allowing a peer that sends data without a newline to exhaust process memory. This issue is fixed in version 0.23.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-63119?

2 open source packages ship an affected version, including mcp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mcp` | RubyGems | All versions | 0.23.0 |
| `mcp` | RubyGems | All versions | 0.23.0 |

## How do I fix CVE-2026-63119?

Upgrade mcp to 0.23.0 or later.

## Is CVE-2026-63119 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63119 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63119 and fix it if it is affected.

What it is: CVE-2026-63119 is a medium-severity denial of service vulnerability in modelcontextprotocol ruby-sdk, published on 29 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63119 exists.

Affected packages and fixed versions:
- mcp (RubyGems): affected all versions; fixed in 0.23.0
- mcp (RubyGems): affected all versions; fixed in 0.23.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63119/ (Markdown: https://insights.sbomify.com/CVE-2026-63119/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63119
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63119
- OSV: https://osv.dev/vulnerability/CVE-2026-63119

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63119/
Summaries are generated and may contain mistakes; the official description above is the record.
