# CVE-2026-63126: Wire: Unauthenticated decoder crash via 32-bit length integer overflow in ByteArrayProtoReader32 (incomplete fix of CVE-2026-45799)

> An attacker can cause a denial of service in the Wire protobuf library by sending malformed data that triggers an integer overflow, leading to crashes or excessive allocation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-9rm7-3qhh-h2mc

## What is CVE-2026-63126?

CVE-2026-63126 is a high-severity vulnerability in square wire, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Wire provides gRPC and protocol buffers for Android, Kotlin, Swift, and Java. Prior to 6.4.5 and 7.0.0-alpha04, Wire protobuf readers do not consistently validate attacker-controlled lengths against the current logical message boundary before advancing cursors, pointers, limits, slices, or allocations. In Kotlin, ProtoAdapter.decode(ByteArray) and ProtoAdapter.decode(ByteString) use ByteArrayProtoReader32.internalNextLengthDelimited(), where a positive oversized length can wrap pos + length to a negative limit and escape the existing negative-length check. Related ProtoReader, ReadBuffer.readVarint(), ReadBuffer.verifyAdditional(count:), packed-repeated, nested-message, and ProtoDecoder.decodeSizeDelimited(_:from:) paths can cross logical boundaries, perform pointer arithmetic, reserve capacity, or convert an unrepresentable size before proving the requested bytes exist. An attacker who supplies malformed protobuf bytes can cause unchecked exceptions, traps, out-of-bounds behavior, or excessive allocation, resulting in denial of service without known confidentiality, integrity, or code-execution impact. This issue is fixed in versions 6.4.5 and 7.0.0-alpha04.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-63126?

4 open source packages ship an affected version, including com.squareup.wire:wire-runtime.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.squareup.wire:wire-runtime` | Maven | All versions | 6.4.5 |
| `com.squareup.wire:wire-runtime` | Maven | All versions | 6.4.5 |
| `com.squareup.wire:wire-runtime` | Maven | From 7.0.0-alpha01 | 7.0.0-alpha04 |
| `com.squareup.wire:wire-runtime` | Maven | From 7.0.0-alpha01 | 7.0.0-alpha04 |

## How do I fix CVE-2026-63126?

Upgrade com.squareup.wire:wire-runtime to a fixed version for your release line: 6.4.5 or 7.0.0-alpha04.

## Is CVE-2026-63126 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63126 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63126 and fix it if it is affected.

What it is: CVE-2026-63126 is a high-severity vulnerability in square wire, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63126 exists.

Affected packages and fixed versions:
- com.squareup.wire:wire-runtime (Maven): affected all versions; fixed in 6.4.5
- com.squareup.wire:wire-runtime (Maven): affected all versions; fixed in 6.4.5
- com.squareup.wire:wire-runtime (Maven): affected from 7.0.0-alpha01; fixed in 7.0.0-alpha04
- com.squareup.wire:wire-runtime (Maven): affected from 7.0.0-alpha01; fixed in 7.0.0-alpha04

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63126/ (Markdown: https://insights.sbomify.com/CVE-2026-63126/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63126
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63126
- OSV: https://osv.dev/vulnerability/CVE-2026-63126

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63126/
Summaries are generated and may contain mistakes; the official description above is the record.
