# CVE-2026-63130: Path traversal in espocrm

> An authenticated administrator can exploit path traversal in EspoCRM's Label Manager to read, write, or delete arbitrary JSON files.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Oct 2026
- **Updated:** 15 Oct 2026
- **Also known as:** GHSA-jr5q-25fw-27f8

## What is CVE-2026-63130?

CVE-2026-63130 is a medium-severity path traversal vulnerability in espocrm, published on 15 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

EspoCRM is an open source customer relationship management application. Prior to 9.3.10, an authenticated administrator can provide crafted input to the administrative Label Manager. Insufficient path validation allows traversal outside the intended directory and permits reading, modifying, creating, or deleting JSON files accessible to the application, subject to filesystem permissions and server configuration. This issue is fixed in version 9.3.10.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-63130?


## How do I fix CVE-2026-63130?

No fix has been published for CVE-2026-63130 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-63130 being exploited?

There is no known exploitation of CVE-2026-63130 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63130 and fix it if it is affected.

What it is: CVE-2026-63130 is a medium-severity path traversal vulnerability in espocrm, published on 15 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-63130 in the wild and no public exploit code.

Affected product: espocrm. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63130/ (Markdown: https://insights.sbomify.com/CVE-2026-63130/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63130
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63130
- OSV: https://osv.dev/vulnerability/CVE-2026-63130

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63130/
Summaries are generated and may contain mistakes; the official description above is the record.
