# CVE-2026-6321: fast-uri vulnerable to path traversal via percent-encoded dot segments

> Attackers can bypass path-based security policies in applications using fast-uri by exploiting improper normalization of percent-encoded dot segments.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 May 2026
- **Updated:** 10 Sep 2026
- **Also known as:** CLEANSTART-2026-RD64552, CLEANSTART-2026-UQ15244, CLSA-2026-1784596352, CLSA-2026-1790854665, DEBIAN-CVE-2026-6321, ECHO-d17c-0010-d1d4, GHSA-q3j6-qgpj-74h6, MINI-24vq-hhvw-x7gp, MINI-2559-95hr-c3wg, MINI-29xw-9782-pc26, MINI-32hr-r657-m49q, MINI-343j-2w6h-763v, MINI-397f-9x7m-rx3r, MINI-46ph-8f96-22wx, MINI-5w75-56x2-grj2, MINI-6mrj-xvjx-pj5c, MINI-799x-xg6w-vvjg, MINI-7v74-6m7h-3h89, MINI-c2q8-pcrx-vcxh, MINI-crq7-rw96-pf6c, MINI-cvmh-mhf7-29c6, MINI-fp7c-9852-9mqf, MINI-frxj-c2m6-4frf, MINI-gwv9-vvw8-r568, MINI-hmgx-7xcg-vq88, MINI-hwxv-wrh3-pc5h, MINI-hxvc-39vm-3cv6, MINI-jmc5-qqv2-wh47, MINI-m85f-2x94-35p7, MINI-pgv4-gcxp-g7m5, MINI-r8w2-vj3j-pjch, MINI-rcc4-gfpp-phxc, MINI-rxpw-rwrp-75qm, MINI-wccx-qg9h-663j, MINI-wgv2-jxpc-x9pc, MINI-whw9-8p7x-j675, MINI-x7pr-qx6c-jm2p, ROOT-APP-NPM-CVE-2026-6321, UBUNTU-CVE-2026-6321, openSUSE-SU-2026:10750-1

## What is CVE-2026-6321?

CVE-2026-6321 is a high-severity path traversal vulnerability in fast-uri, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fast-uri decoded percent-encoded path separators and dot segments before applying dot-segment removal in its normalize() and equal() functions. Encoded path data was treated like real slashes and parent-directory references, so distinct URIs could collapse onto the same normalized path. Applications that normalize or compare attacker-controlled URLs to enforce path-based policy can be bypassed, with a path that appears confined under an allowed prefix normalizing to a different location. Versions <= 3.1.0 are affected. Update to 3.1.1 or later.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-6321?

4 open source packages ship an affected version, including fast-uri. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-uri` | npm | All versions | 2.4.1 |
| `fast-uri` | npm | All versions | 2.4.1 |
| `fast-uri` | npm | From 3.0.0 | 3.1.1 |
| `fast-uri` | npm | From 3.0.0 | 3.1.1 |
| `python-pydata-sphinx-theme` | openSUSE:Tumbleweed | All versions | 0.17.1-1.1 |

Products: Openjsf Fast-Uri.

## How do I fix CVE-2026-6321?

Upgrade fast-uri to a fixed version for your release line: 2.4.1 or 3.1.1.

## Is CVE-2026-6321 being exploited?

There is no known exploitation of CVE-2026-6321 in the wild and no public exploit code.

## Other vulnerabilities in fast-uri

- [CVE-2026-84292](https://insights.sbomify.com/CVE-2026-84292/): fast-uri vulnerable to authority injection via an unvalidated port in serialize (high 7.5)
- [CVE-2026-84394](https://insights.sbomify.com/CVE-2026-84394/): fast-uri vulnerable to host confusion via an unclosed bracket in the URI authority (high 7.5)
- [CVE-2026-75899](https://insights.sbomify.com/CVE-2026-75899/): fast-uri vulnerable to server-side request forgery via repeated hostname percent-decoding (high 7.5)
- [CVE-2026-75931](https://insights.sbomify.com/CVE-2026-75931/): fast-uri vulnerable to host confusion via skipped IDN canonicalization on scheme-relative references (high 7.5)
- [CVE-2026-75975](https://insights.sbomify.com/CVE-2026-75975/): fast-uri vulnerable to server-side request forgery via malformed IPv6 normalization (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6321 and fix it if it is affected.

What it is: CVE-2026-6321 is a high-severity path traversal vulnerability in fast-uri, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-6321 in the wild and no public exploit code.

Affected packages and fixed versions:
- fast-uri (npm): affected all versions; fixed in 2.4.1
- fast-uri (npm): affected all versions; fixed in 2.4.1
- fast-uri (npm): affected from 3.0.0; fixed in 3.1.1
- fast-uri (npm): affected from 3.0.0; fixed in 3.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6321/ (Markdown: https://insights.sbomify.com/CVE-2026-6321/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6321
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6321
- OSV: https://osv.dev/vulnerability/CVE-2026-6321

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6321/
Summaries are generated and may contain mistakes; the official description above is the record.
