# CVE-2026-63216: Zammad: Stored XSS via unescaped option labels in the object attribute options context UI

> Attackers can inject malicious scripts via unescaped option labels in Zammad's admin UI, executing code in admin browsers.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-r95m-ghj7-646x

## What is CVE-2026-63216?

CVE-2026-63216 is a medium-severity cross-site scripting vulnerability in zammad, published on 25 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Zammad is a web based open source helpdesk/customer support system. Prior to 7.1.2, unsanitized option labels are rendered in the configuration dialogs of AI Agents within Zammad's admin UI. When rendering the list of selected options, the option label is output as raw HTML without escaping. An attacker who can control an option label, for example by setting a malicious string as a user or organization name used in a relation attribute, or by supplying a crafted custom attribute option value, can inject arbitrary HTML and JavaScript. The payload executes in the browser of any admin or agent who opens the affected object attribute configuration view. This issue is fixed in version 7.1.2.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2026-63216?


## How do I fix CVE-2026-63216?

No fix has been published for CVE-2026-63216 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-63216 being exploited?

There is no known exploitation of CVE-2026-63216 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63216 and fix it if it is affected.

What it is: CVE-2026-63216 is a medium-severity cross-site scripting vulnerability in zammad, published on 25 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-63216 in the wild and no public exploit code.

Affected product: zammad. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63216/ (Markdown: https://insights.sbomify.com/CVE-2026-63216/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63216
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63216
- OSV: https://osv.dev/vulnerability/CVE-2026-63216

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63216/
Summaries are generated and may contain mistakes; the official description above is the record.
