# CVE-2026-6322: fast-uri vulnerable to host confusion via percent-encoded authority delimiters

> Attackers can bypass host allowlists and redirect requests by exploiting percent-encoded authority delimiters in URI normalization.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2026
- **Updated:** 10 Sep 2026
- **Also known as:** CLEANSTART-2026-CH75169, CLEANSTART-2026-KV71564, DEBIAN-CVE-2026-6322, ECHO-9cc9-e37b-d919, GHSA-v39h-62p7-jpjc, MINI-3295-78cv-8c8c, MINI-3ch5-f9fg-5qp8, MINI-3pw3-frhj-pv3p, MINI-42cq-h6cq-xfr2, MINI-5488-h8vx-jg8x, MINI-55pm-3v8m-28hr, MINI-5v3h-v9jj-qcm9, MINI-68h2-8pv2-96rg, MINI-6ghw-h6v8-292r, MINI-9fv3-3f35-346g, MINI-9xxm-jwjc-42wj, MINI-ccrf-2qmw-9mf5, MINI-f8r3-3p4r-m872, MINI-fvwj-fhc5-6pgh, MINI-g4g3-m5f4-xp8m, MINI-g5h7-fx6q-rvr9, MINI-j328-j6jx-8mf6, MINI-jjfj-mcfr-5mrm, MINI-mwrw-w5vw-3pq9, MINI-p299-f2h9-wqgr, MINI-p99h-xv57-w5w4, MINI-pvmp-rxwq-qx2p, MINI-q3c8-jwfj-vh59, MINI-rcr9-hpj3-gw7p, MINI-rp5q-r7mj-g6rh, MINI-rpm9-hmc7-7h3q, MINI-v848-7g7m-69jv, MINI-vcg6-vf7j-h8v7, MINI-w4qq-57c5-qfm4, MINI-wg44-j4w5-c72f, MINI-wjg3-r6xh-jg3v, MINI-x96x-qh8f-49cj, ROOT-APP-NPM-CVE-2026-6322, UBUNTU-CVE-2026-6322

## What is CVE-2026-6322?

CVE-2026-6322 is a high-severity server-side request forgery vulnerability in fast-uri, published on 5 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fast-uri normalize() decoded percent-encoded authority delimiters inside the host component and then re-emitted them as raw delimiters during serialization. A host that combined an allowed domain, an encoded at-sign, and a different domain was re-emitted with the at-sign as a raw userinfo separator, changing the URI's authority to the second domain. Applications that normalize untrusted URLs before host allowlist checks, redirect validation, or outbound request routing can be steered to a different authority than the input appeared to specify. Versions <= 3.1.1 are affected. Update to 3.1.2 or later.

Weakness: CWE-140 (Improper Neutralization of Delimiters), CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2026-6322?

4 open source packages ship an affected version, including fast-uri. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-uri` | npm | All versions | 2.4.1 |
| `fast-uri` | npm | All versions | 2.4.1 |
| `fast-uri` | npm | From 3.0.0 | 3.1.2 |
| `fast-uri` | npm | From 3.0.0 | 3.1.2 |

Products: Openjsf Fast-Uri.

## How do I fix CVE-2026-6322?

Upgrade fast-uri to a fixed version for your release line: 2.4.1 or 3.1.2.

## Is CVE-2026-6322 being exploited?

There is no known exploitation of CVE-2026-6322 in the wild and no public exploit code.

## Other vulnerabilities in fast-uri

- [CVE-2026-84292](https://insights.sbomify.com/CVE-2026-84292/): fast-uri vulnerable to authority injection via an unvalidated port in serialize (high 7.5)
- [CVE-2026-84394](https://insights.sbomify.com/CVE-2026-84394/): fast-uri vulnerable to host confusion via an unclosed bracket in the URI authority (high 7.5)
- [CVE-2026-75899](https://insights.sbomify.com/CVE-2026-75899/): fast-uri vulnerable to server-side request forgery via repeated hostname percent-decoding (high 7.5)
- [CVE-2026-75931](https://insights.sbomify.com/CVE-2026-75931/): fast-uri vulnerable to host confusion via skipped IDN canonicalization on scheme-relative references (high 7.5)
- [CVE-2026-75975](https://insights.sbomify.com/CVE-2026-75975/): fast-uri vulnerable to server-side request forgery via malformed IPv6 normalization (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6322 and fix it if it is affected.

What it is: CVE-2026-6322 is a high-severity server-side request forgery vulnerability in fast-uri, published on 5 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-6322 in the wild and no public exploit code.

Affected packages and fixed versions:
- fast-uri (npm): affected all versions; fixed in 2.4.1
- fast-uri (npm): affected all versions; fixed in 2.4.1
- fast-uri (npm): affected from 3.0.0; fixed in 3.1.2
- fast-uri (npm): affected from 3.0.0; fixed in 3.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6322/ (Markdown: https://insights.sbomify.com/CVE-2026-6322/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6322
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6322
- OSV: https://osv.dev/vulnerability/CVE-2026-6322

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6322/
Summaries are generated and may contain mistakes; the official description above is the record.
