{"answers":{"affected":"2 open source packages ship an affected version, including codeigniter4/framework.","exploited":"There is no known exploitation of CVE-2026-63220 in the wild and no public exploit code.","fix":"Upgrade codeigniter4/framework to 4.7.4 or later.","what":"CVE-2026-63220 is a medium-severity vulnerability in CodeIgniter4, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-63220 and fix it if it is affected.\n\nWhat it is: CVE-2026-63220 is a medium-severity vulnerability in CodeIgniter4, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-63220 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- codeigniter4/framework (Packagist): affected all versions; fixed in 4.7.4\n- codeigniter4/framework (Packagist): affected all versions; fixed in 4.7.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-63220/ (Markdown: https://insights.sbomify.com/CVE-2026-63220/index.md)","id":"CVE-2026-63220","markdown":"https://insights.sbomify.com/CVE-2026-63220/index.md","name":"CVE-2026-63220","record":{"aliases":["GHSA-7wmf-pw8j-mc78","UBUNTU-CVE-2026-63220"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP web framework","requires_auth":"none","summary":"Attackers can spoof HTTPS headers to bypass secure connection checks in CodeIgniter applications, potentially exposing sensitive data or allowing insecure access.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-348","name":"Use of Less Trusted Source"}],"description":"CodeIgniter is a PHP full-stack web framework. In versions prior to 4.7.4, IncomingRequest::isSecure() trusted the X-Forwarded-Proto and Front-End-Https headers from any incoming request, allowing an attacker could spoof these headers and cause the application to incorrectly treat an HTTP request as secure. This may have impacted applications that rely on isSecure(), force_https(), forceGlobalSecureRequests, or similar logic to enforce HTTPS-only access or make security-sensitive decisions. Exploitability depends on deployment configuration. Applications are most exposed if the backend is reachable directly over HTTP, or if a reverse proxy/load balancer forwards client-supplied forwarding headers without stripping or overwriting them. This issue has been fixed in version 4.7.4.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CodeIgniter: Spoofable forwarded HTTPS headers in IncomingRequest::isSecure()","id":"CVE-2026-63220","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"CodeIgniter: SQL injection is possible via Query Builder deleteBatch() when used with where() conditions","id":"CVE-2026-63221"},"packages":[{"ecosystem":"Packagist","fixed":["4.7.4"],"introduced":["0"],"last_affected":[],"package":"codeigniter4/framework","purl":null,"source":"GHSA-7wmf-pw8j-mc78"},{"ecosystem":"Packagist","fixed":["4.7.4"],"introduced":["0"],"last_affected":[],"package":"codeigniter4/framework","purl":"pkg:composer/codeigniter4/framework","source":"GHSA-7wmf-pw8j-mc78"}],"prev":{"headline":"Unauthenticated file upload via missing authorization on formatter upload endpoint","id":"CVE-2026-63219"},"products":["CodeIgniter4"],"published":"2026-07-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-31","vendors":["codeigniter4"]},"summary":"Attackers can spoof HTTPS headers to bypass secure connection checks in CodeIgniter applications, potentially exposing sensitive data or allowing insecure access.","url":"https://insights.sbomify.com/CVE-2026-63220/"}