# CVE-2026-63220: CodeIgniter: Spoofable forwarded HTTPS headers in IncomingRequest::isSecure()

> Attackers can spoof HTTPS headers to bypass secure connection checks in CodeIgniter applications, potentially exposing sensitive data or allowing insecure access.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jul 2026
- **Updated:** 31 Jul 2026
- **Also known as:** GHSA-7wmf-pw8j-mc78, UBUNTU-CVE-2026-63220

## What is CVE-2026-63220?

CVE-2026-63220 is a medium-severity vulnerability in CodeIgniter4, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CodeIgniter is a PHP full-stack web framework. In versions prior to 4.7.4, IncomingRequest::isSecure() trusted the X-Forwarded-Proto and Front-End-Https headers from any incoming request, allowing an attacker could spoof these headers and cause the application to incorrectly treat an HTTP request as secure. This may have impacted applications that rely on isSecure(), force_https(), forceGlobalSecureRequests, or similar logic to enforce HTTPS-only access or make security-sensitive decisions. Exploitability depends on deployment configuration. Applications are most exposed if the backend is reachable directly over HTTP, or if a reverse proxy/load balancer forwards client-supplied forwarding headers without stripping or overwriting them. This issue has been fixed in version 4.7.4.

Weakness: CWE-348 (Use of Less Trusted Source)

## Which versions are affected by CVE-2026-63220?

2 open source packages ship an affected version, including codeigniter4/framework.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codeigniter4/framework` | Packagist | All versions | 4.7.4 |
| `codeigniter4/framework` | Packagist | All versions | 4.7.4 |

## How do I fix CVE-2026-63220?

Upgrade codeigniter4/framework to 4.7.4 or later.

## Is CVE-2026-63220 being exploited?

There is no known exploitation of CVE-2026-63220 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63220 and fix it if it is affected.

What it is: CVE-2026-63220 is a medium-severity vulnerability in CodeIgniter4, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-63220 in the wild and no public exploit code.

Affected packages and fixed versions:
- codeigniter4/framework (Packagist): affected all versions; fixed in 4.7.4
- codeigniter4/framework (Packagist): affected all versions; fixed in 4.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63220/ (Markdown: https://insights.sbomify.com/CVE-2026-63220/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63220
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63220
- OSV: https://osv.dev/vulnerability/CVE-2026-63220

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63220/
Summaries are generated and may contain mistakes; the official description above is the record.
