# CVE-2026-63221: CodeIgniter: SQL injection is possible via Query Builder deleteBatch() when used with where() conditions

> Attackers can execute arbitrary SQL commands via the deleteBatch method in CodeIgniter, potentially reading or modifying database contents.

- **Severity:** Critical 9.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jul 2026
- **Updated:** 31 Jul 2026
- **Also known as:** GHSA-c9w5-rwh3-7pm9, UBUNTU-CVE-2026-63221

## What is CVE-2026-63221?

CVE-2026-63221 is a critical SQL injection vulnerability in CodeIgniter4, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CodeIgniter is a PHP full-stack web framework. From 4.3.0 through 4.7.3, Query Builder deleteBatch() substitutes bound values from where() conditions into generated SQL while ignoring their escape flags, allowing user-controlled condition values to be interpreted as SQL. This affects only the deleteBatch() code path. Regular delete() operations escape where() binds correctly. This issue is fixed in version 4.7.4.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-63221?

2 open source packages ship an affected version, including codeigniter4/framework.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codeigniter4/framework` | Packagist | From 4.3.0 | 4.7.4 |
| `codeigniter4/framework` | Packagist | From 4.3.0 | 4.7.4 |

## How do I fix CVE-2026-63221?

Upgrade codeigniter4/framework to 4.7.4 or later.

## Is CVE-2026-63221 being exploited?

There is no known exploitation of CVE-2026-63221 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63221 and fix it if it is affected.

What it is: CVE-2026-63221 is a critical SQL injection vulnerability in CodeIgniter4, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-63221 in the wild and no public exploit code.

Affected packages and fixed versions:
- codeigniter4/framework (Packagist): affected from 4.3.0; fixed in 4.7.4
- codeigniter4/framework (Packagist): affected from 4.3.0; fixed in 4.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63221/ (Markdown: https://insights.sbomify.com/CVE-2026-63221/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63221
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63221
- OSV: https://osv.dev/vulnerability/CVE-2026-63221

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63221/
Summaries are generated and may contain mistakes; the official description above is the record.
