# CVE-2026-63222: CodeIgniter: Path traversal in UploadedFile::move() when using client-provided filenames

> Remote attackers can write files outside intended directories via path traversal in CodeIgniter's file upload handling.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jul 2026
- **Updated:** 31 Jul 2026
- **Also known as:** GHSA-hhmc-q9hp-r662, UBUNTU-CVE-2026-63222

## What is CVE-2026-63222?

CVE-2026-63222 is a high-severity path traversal vulnerability in CodeIgniter4, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CodeIgniter is a PHP full-stack web framework. Prior to 4.7.4, calling UploadedFile::move() without a second argument uses the client-provided filename without sanitization, allowing a remote attacker to use path traversal sequences to write uploaded content outside the intended directory when the application exposes an upload path. This issue is fixed in version 4.7.4.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-63222?

2 open source packages ship an affected version, including codeigniter4/framework.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codeigniter4/framework` | Packagist | All versions | 4.7.4 |
| `codeigniter4/framework` | Packagist | All versions | 4.7.4 |

## How do I fix CVE-2026-63222?

Upgrade codeigniter4/framework to 4.7.4 or later.

## Is CVE-2026-63222 being exploited?

There is no known exploitation of CVE-2026-63222 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63222 and fix it if it is affected.

What it is: CVE-2026-63222 is a high-severity path traversal vulnerability in CodeIgniter4, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-63222 in the wild and no public exploit code.

Affected packages and fixed versions:
- codeigniter4/framework (Packagist): affected all versions; fixed in 4.7.4
- codeigniter4/framework (Packagist): affected all versions; fixed in 4.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63222/ (Markdown: https://insights.sbomify.com/CVE-2026-63222/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63222
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63222
- OSV: https://osv.dev/vulnerability/CVE-2026-63222

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63222/
Summaries are generated and may contain mistakes; the official description above is the record.
