CVE-2026-63292 Apache HTTP Server: mod_vhost_alias stack overflow
Remote attackers can cause denial of service or execute code via stack overflow in Apache mod_vhost_alias when specific non-default configurations are enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-63292?
CVE-2026-63292 is a high-severity memory corruption vulnerability in Apache Http Server, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Stack-based buffer overflow in mod_vhost_alias in Apache Software Foundation Apache HTTP Server through 2.4.68 on all platforms allows a remote client to cause a denial of service or potentially execute arbitrary code via an HTTP request with a Host header exceeding 8192 bytes when VirtualDocumentRoot uses a hostname format specifier and LimitRequestFieldSize is raised above the default.
Users are recommended to upgrade to version 2.4.69, which fixes this issue.
Weakness: CWE-121
Which versions are affected by CVE-2026-63292?
1 open source package ship an affected version, including apache. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache Bitnami | From 2.4.0 | 2.4.69 |
Products include Apache Http Server.
How do I fix CVE-2026-63292?
Upgrade apache to 2.4.69 or later.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2026-63292 being exploited?
There is no known exploitation of CVE-2026-63292 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Http Server
Sources
Also known as ALPINE-CVE-2026-63292, AZL-106485, BELL-CVE-2026-63292, BIT-apache-2026-63292, CLSA-2026-1791487799, CLSA-2026-1791487835 and 6 more.