# CVE-2026-63308: Helm Files.Lines Denial of Service via Empty Chart Files

> Attackers can cause Helm to crash by including empty files in charts, disrupting template rendering and deployment operations.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Jul 2026
- **Updated:** 29 Oct 2026
- **Also known as:** AZL-92991, BIT-helm-2026-63308, GHSA-5gjx-96wq-c8r2, MINI-3h5r-v57f-2v9h, MINI-4c6c-3qrw-2xh6, MINI-p7jr-v694-qfc7, MINI-wf7p-g9fq-5h3j, RHSA-2026:55180, openSUSE-SU-2026:11386-1, openSUSE-SU-2026:11387-1

## What is CVE-2026-63308?

CVE-2026-63308 is a medium-severity denial of service vulnerability in helm, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Helm through 4.2.3, fixed in commit ba6c9a2, contains a denial of service vulnerability in the Files.Lines template helper in pkg/engine/files.go that allows attackers to trigger an index out of range panic by including zero-length byte slices in chart files. Attackers can include empty files in Helm charts to cause deterministic render failures across template, install, upgrade, lint, and SDK Engine.Render operations.

Weakness: CWE-129 (Improper Validation of Array Index)

## Which versions are affected by CVE-2026-63308?

1 open source package ship an affected version, including helm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `helm` | Bitnami | All versions | 4.2.4 |
| `helm3` | Red Hat:hummingbird:1 | All versions | 0:3.21.4-0.1.hum1 |
| `helm` | openSUSE:Tumbleweed | All versions | 4.2.3-4.1 |
| `helm3` | openSUSE:Tumbleweed | All versions | 3.21.3-4.1 |

Products: Helm Helm.

## How do I fix CVE-2026-63308?

Upgrade helm to 4.2.4 or later.

## Is CVE-2026-63308 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63308 exists.

## Other vulnerabilities in helm

- [CVE-2019-18658](https://insights.sbomify.com/CVE-2019-18658/): Helm Unsafe Link Following (critical 9.8)
- [CVE-2019-1010275](https://insights.sbomify.com/CVE-2019-1010275/): Helm Improper Certificate Validation (critical 9.8)
- [CVE-2019-25210](https://insights.sbomify.com/CVE-2019-25210/): Information disclosure in n/a (critical 9.1)
- [CVE-2025-53547](https://insights.sbomify.com/CVE-2025-53547/): Helm Chart Dependency Updating With Malicious Chart.yaml Content And Symlink Can Lead To Code Execution (high 8.5)
- [CVE-2020-11013](https://insights.sbomify.com/CVE-2020-11013/): lookup Function Information Discolosure in Helm (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63308 and fix it if it is affected.

What it is: CVE-2026-63308 is a medium-severity denial of service vulnerability in helm, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63308 exists.

Affected packages and fixed versions:
- helm (Bitnami): affected all versions; fixed in 4.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63308/ (Markdown: https://insights.sbomify.com/CVE-2026-63308/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63308
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63308
- OSV: https://osv.dev/vulnerability/CVE-2026-63308

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63308/
Summaries are generated and may contain mistakes; the official description above is the record.
