# CVE-2026-63311: NLTK before 3.10.0 SSRF via DNS Resolution Failure

> Attackers can bypass SSRF protections in NLTK via DNS failures to access restricted network resources, including cloud metadata endpoints.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:L/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Aug 2026
- **Updated:** 26 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-63311, ECHO-2c96-e20c-40c3, GHSA-3gqm-fcw5-w839, MINI-98jg-5c66-g23m, PYSEC-2026-3723, UBUNTU-CVE-2026-63311

## What is CVE-2026-63311?

CVE-2026-63311 is a medium-severity server-side request forgery vulnerability in nltk, published on 22 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NLTK before 3.10.0 (affected versions <= 3.9.4) contains a server-side request forgery (SSRF) vulnerability in the validate_network_url() function in nltk/pathsec.py. The _resolve_hostname() helper catches OSError and ValueError during socket.getaddrinfo() and returns an empty list; when DNS resolution fails, the validation loop executes no IP checks and the function fails open, allowing urlopen() to proceed without validation. An attacker who can trigger DNS resolution failures or use DNS rebinding can bypass SSRF protections and reach restricted network resources, including cloud metadata endpoints (e.g., 169.254.169.254).

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-63311?

3 open source packages ship an affected version, including nltk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nltk` | PyPI | All versions | 3.10.0 |
| `nltk` | PyPI | All versions | 3.10.0 |
| `nltk` | PyPI | All versions | 3.10.0 |

Products: Nltk Nltk.

## How do I fix CVE-2026-63311?

Upgrade nltk to 3.10.0 or later.

## Is CVE-2026-63311 being exploited?

There is no known exploitation of CVE-2026-63311 in the wild and no public exploit code.

## Other vulnerabilities in nltk

- [CVE-2026-0848](https://insights.sbomify.com/CVE-2026-0848/): Arbitrary Code Execution in NLTK StanfordSegmenter via Untrusted JAR Loading (critical 10.0)
- [CVE-2025-14009](https://insights.sbomify.com/CVE-2025-14009/): Zip Slip Vulnerability in nltk/nltk Leading to Remote Code Execution (critical 10.0)
- [CVE-2026-78683](https://insights.sbomify.com/CVE-2026-78683/): NLTK before 3.10.0 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.4)
- [CVE-2026-79657](https://insights.sbomify.com/CVE-2026-79657/): NLTK before 3.10.3 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.3)
- [CVE-2026-79675](https://insights.sbomify.com/CVE-2026-79675/): NLTK before 3.10.3 JVM Argument Injection via Per-Call Options (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63311 and fix it if it is affected.

What it is: CVE-2026-63311 is a medium-severity server-side request forgery vulnerability in nltk, published on 22 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-63311 in the wild and no public exploit code.

Affected packages and fixed versions:
- nltk (PyPI): affected all versions; fixed in 3.10.0
- nltk (PyPI): affected all versions; fixed in 3.10.0
- nltk (PyPI): affected all versions; fixed in 3.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63311/ (Markdown: https://insights.sbomify.com/CVE-2026-63311/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63311
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63311
- OSV: https://osv.dev/vulnerability/CVE-2026-63311

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63311/
Summaries are generated and may contain mistakes; the official description above is the record.
