{"answers":{"affected":"2 open source packages ship an affected version, including com.rabbitmq:amqp-client.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63337 exists.","fix":"Upgrade com.rabbitmq:amqp-client to 5.33.0 or later.","what":"CVE-2026-63337 is a high-severity code injection vulnerability in rabbitmq-java-client, published on 18 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-63337 and fix it if it is affected.\n\nWhat it is: CVE-2026-63337 is a high-severity code injection vulnerability in rabbitmq-java-client, published on 18 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63337 exists.\n\nAffected packages and fixed versions:\n- com.rabbitmq:amqp-client (Maven): affected all versions; fixed in 5.33.0\n- com.rabbitmq:amqp-client (Maven): affected all versions; fixed in 5.33.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-63337/ (Markdown: https://insights.sbomify.com/CVE-2026-63337/index.md)","id":"CVE-2026-63337","markdown":"https://insights.sbomify.com/CVE-2026-63337/index.md","name":"CVE-2026-63337","record":{"aliases":["CLEANSTART-2026-ED93010","DEBIAN-CVE-2026-63337","ECHO-7592-392e-0fc2","GHSA-6g32-pxv4-2wfj","MINI-3fwg-j683-4hc8","MINI-3j57-xv6x-cf6w","MINI-73fr-48ch-9pvx","MINI-872w-m3r3-3h6x","MINI-8xfw-p47x-m7pp","MINI-fm27-fp9v-mmv8","MINI-fwxq-2633-ph9c","MINI-fxf7-8rv8-vv2v","MINI-gjqq-r22f-9hh9","MINI-jg66-m568-2v6j","MINI-m2qj-h7gm-534m","MINI-p5qq-pc8w-3p89","MINI-qhxw-28gr-rgmw","MINI-rph3-c436-v4fh","MINI-v5q6-9vh8-fqq2","ROOT-APP-MAVEN-CVE-2026-63337","UBUNTU-CVE-2026-63337"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"RabbitMQ Java client","requires_auth":"low_privilege","summary":"An attacker can trigger arbitrary class loading and static initializer execution in the RabbitMQ Java client by manipulating JSON-RPC responses, leading to code execution or denial of service.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L","version":"4.0"},"cwes":[{"id":"CWE-470","name":"Use of Externally-Controlled Input to Select Classes or Code"}],"description":"The RabbitMQ Java client library allows Java and JVM-based applications to connect to and interact with RabbitMQ nodes. Prior to 5.33.0, com.rabbitmq.tools.jsonrpc.ProcedureDescription receives a javaReturnType value in an untrusted system.describe response and passes it through JSONUtil.tryFill, setJavaReturnType, and computeReturnTypeAsJavaClass to Class.forName(javaReturnType) with initialization enabled. An attacker able to answer the JsonRpcClient request through a shared broker or network interception can select a class already present in the victim JVM and trigger its static initializer, while JsonRpcClient.java later passes getReturnType output to mapper.parse and may also create type confusion. Successful exploitation can affect confidentiality, integrity, and availability in the client process. This issue is fixed in version 5.33.0.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"RabbitMQ Java client: Unvalidated Class.forName in JSON-RPC ProcedureDescription enables arbitrary class loading","id":"CVE-2026-63337","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":6,"next":{"headline":"Hatchet: Cross-Tenant Durable Task Event Log Disclosure via Missing Authorization Check","id":"CVE-2026-63342"},"packages":[{"ecosystem":"Maven","fixed":["5.33.0"],"introduced":["0"],"last_affected":[],"package":"com.rabbitmq:amqp-client","purl":null,"source":"GHSA-6g32-pxv4-2wfj"},{"ecosystem":"Maven","fixed":["5.33.0"],"introduced":["0"],"last_affected":[],"package":"com.rabbitmq:amqp-client","purl":"pkg:maven/com.rabbitmq/amqp-client","source":"GHSA-6g32-pxv4-2wfj"}],"prev":{"headline":"RabbitMQ Java client: TrustEverythingTrustManager used by default in useSslProtocol() enables MITM","id":"CVE-2026-63336"},"products":["rabbitmq-java-client"],"published":"2026-08-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-18","vendors":["rabbitmq"]},"summary":"An attacker can trigger arbitrary class loading and static initializer execution in the RabbitMQ Java client by manipulating JSON-RPC responses, leading to code execution or denial of service.","url":"https://insights.sbomify.com/CVE-2026-63337/"}