CVE-2026-6334 OAuth authorization code client binding not enforced during token redemption in Mattermost

Low 3.1 Published Updated

An authenticated OAuth client can redeem authorization codes issued to other clients, potentially leading to unauthorized access or account takeover.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-6334?

CVE-2026-6334 is a low-severity authentication bypass vulnerability in Mattermost Mattermost Server, published on 18 May 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13 fail to enforce client identity binding during the OAuth authorization code redemption flow which allows an authenticated OAuth client to redeem authorization codes issued to a different client via a crafted token exchange request.. Mattermost Advisory ID: MMSA-2026-00570

Weakness: CWE-305

Which versions are affected by CVE-2026-6334?

12 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20260318173148-e9ae890a013b
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20260318173148-e9ae890a013b
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20260318173148-e9ae890a013b
github.com/mattermost/mattermost/server/v8 GoFrom 10.11.010.11.14
github.com/mattermost/mattermost/server/v8 GoFrom 10.11.010.11.14
github.com/mattermost/mattermost/server/v8 GoFrom 11.5.011.5.2
6 more packages
github.com/mattermost/mattermost/server/v8 GoFrom 11.5.011.5.2
github.com/mattermost/mattermost-server GoAll versions5.3.2-0.20260318173148-e9ae890a013b
github.com/mattermost/mattermost-server GoAll versions5.3.2-0.20260318173148-e9ae890a013b
github.com/mattermost/mattermost-server GoFrom 10.11.0+incompatible10.11.14+incompatible, 11.5.2+incompatible
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone

Products include Mattermost Mattermost Server.

How do I fix CVE-2026-6334?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20260318173148-e9ae890a013b, 10.11.14 or 11.5.2.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-6334 being exploited?

There is no known exploitation of CVE-2026-6334 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-jp3f-x449-4q75, GO-2026-5474.

Is CVE-2026-6334 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free