# CVE-2026-63379: Libevent: HTTP Header smuggling

> Remote attackers can exploit HTTP header smuggling in Libevent to bypass authorization, spoof proxy headers, or poison caches by manipulating chunked trailers.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** AZL-96903, AZL-96941, AZL-97533, AZL-97557, BELL-CVE-2026-63379, DEBIAN-CVE-2026-63379, ECHO-37ec-7e98-5f4f, GHSA-2gmv-p5m7-98p6, UBUNTU-CVE-2026-63379

## What is CVE-2026-63379?

CVE-2026-63379 is a medium-severity vulnerability in libevent, published on 20 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Libevent is an event notification library. Prior to 2.1.13 and 2.2.2-alpha, libevent processes chunked HTTP trailers in http.c through evhttp_read_trailer and merges them into request headers. The fix introduces evhttp_parse_headers_impl_ and a temporary trailer header list. An unauthenticated remote attacker can place security-sensitive fields in trailers so that an upstream proxy and the libevent application interpret different effective headers, enabling header smuggling, authorization bypass, proxy-header spoofing, or cache poisoning. The fix parses trailers into a temporary header list and discards them instead of merging them into req->input_headers. This issue is fixed in versions 2.1.13 and 2.2.2-alpha.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2026-63379?


## How do I fix CVE-2026-63379?

Upgrade to a fixed version.

## Is CVE-2026-63379 being exploited?

There is no known exploitation of CVE-2026-63379 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63379 and fix it if it is affected.

What it is: CVE-2026-63379 is a medium-severity vulnerability in libevent, published on 20 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-63379 in the wild and no public exploit code.

Affected product: libevent. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63379/ (Markdown: https://insights.sbomify.com/CVE-2026-63379/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63379
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63379
- OSV: https://osv.dev/vulnerability/CVE-2026-63379

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63379/
Summaries are generated and may contain mistakes; the official description above is the record.
