# CVE-2026-63381: Libevent: Dangling Pointer in `evbuffer_add_buffer_reference`

> A use-after-free in Libevent allows attackers to cause memory corruption or crashes via crafted buffer states, requiring an upgrade to patched versions.

- **Severity:** Medium 5.8 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2026
- **Updated:** 21 Aug 2026
- **Also known as:** AZL-96915, AZL-96953, AZL-97527, AZL-97545, BELL-CVE-2026-63381, DEBIAN-CVE-2026-63381, ECHO-b3a5-0d83-0d17, GHSA-c2pj-cg4r-88c8, ROOT-OS-DEBIAN-11-CVE-2026-63381, UBUNTU-CVE-2026-63381

## What is CVE-2026-63381?

CVE-2026-63381 is a medium-severity use after free vulnerability in libevent, published on 20 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Libevent is an event notification library. Prior to 2.1.13 and 2.2.2-alpha, libevent has a use-after-free in buffer.c when evbuffer_add_buffer_reference processes an output buffer whose out_total_len is zero. evbuffer_free_all_chains frees the initial empty chain without resetting outbuf->first, outbuf->last, or outbuf->last_with_datap, and APPEND_CHAIN_MULTICAST subsequently dereferences the dangling chain pointer. A caller that can drive this buffer state can cause memory corruption or a process crash. This issue is fixed in versions 2.1.13 and 2.2.2-alpha.

Weakness: CWE-908 (Use of Uninitialized Resource)

## Which versions are affected by CVE-2026-63381?


## How do I fix CVE-2026-63381?

Upgrade to a fixed version.

## Is CVE-2026-63381 being exploited?

There is no known exploitation of CVE-2026-63381 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63381 and fix it if it is affected.

What it is: CVE-2026-63381 is a medium-severity use after free vulnerability in libevent, published on 20 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-63381 in the wild and no public exploit code.

Affected product: libevent. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63381/ (Markdown: https://insights.sbomify.com/CVE-2026-63381/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63381
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63381
- OSV: https://osv.dev/vulnerability/CVE-2026-63381

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63381/
Summaries are generated and may contain mistakes; the official description above is the record.
