# CVE-2026-63382: libevent evhttp: Multiple HTTP Parser Bugs Enable Request Smuggling

> An unauthenticated remote attacker can exploit HTTP parser inconsistencies in libevent to perform request smuggling, bypassing access controls or poisoning caches.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:L/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2026
- **Updated:** 20 Aug 2026
- **Also known as:** AZL-96900, AZL-96944, AZL-97536, AZL-97560, BELL-CVE-2026-63382, CLSA-2026-1792718226, DEBIAN-CVE-2026-63382, ECHO-ea71-be9c-766f, GHSA-q39v-w2g7-gr8j, ROOT-OS-DEBIAN-11-CVE-2026-63382, UBUNTU-CVE-2026-63382

## What is CVE-2026-63382?

CVE-2026-63382 is a critical vulnerability in libevent, published on 20 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Libevent is an event notification library. Prior to 2.1.13 and 2.2.2-alpha, the libevent evhttp parser in http.c inconsistently handles duplicate Transfer-Encoding headers, comma-separated Transfer-Encoding values, and bare line feeds in chunked framing. evhttp_find_header can select only the first header, evhttp_check_transfer_encoding_ was absent so the previous whole-string comparison fails to recognize valid lists ending in chunked, and evhttp_handle_chunked_read uses EVBUFFER_EOL_CRLF rather than EVBUFFER_EOL_CRLF_STRICT, accepting bare LF chunk terminators. When libevent is deployed behind a proxy that frames the same request differently, an unauthenticated remote attacker can desynchronize request boundaries and smuggle a second request, potentially bypassing access controls or poisoning caches. This issue is fixed in versions 2.1.13 and 2.2.2-alpha.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2026-63382?


## How do I fix CVE-2026-63382?

Upgrade to a fixed version.

## Is CVE-2026-63382 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63382 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63382 and fix it if it is affected.

What it is: CVE-2026-63382 is a critical vulnerability in libevent, published on 20 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63382 exists.

Affected product: libevent. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63382/ (Markdown: https://insights.sbomify.com/CVE-2026-63382/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63382
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63382
- OSV: https://osv.dev/vulnerability/CVE-2026-63382

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63382/
Summaries are generated and may contain mistakes; the official description above is the record.
