# CVE-2026-63383: Libevent: decode_tag_internal() can lead to out-of-bounds read

> An out-of-bounds read in Libevent's RPC decoding allows attackers to crash applications processing malformed tagged data.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2026
- **Updated:** 20 Aug 2026
- **Also known as:** AZL-96921, AZL-96938, AZL-97521, AZL-97551, BELL-CVE-2026-63383, DEBIAN-CVE-2026-63383, ECHO-c210-992e-640a, GHSA-fj29-64w6-73h6, ROOT-OS-DEBIAN-11-CVE-2026-63383, UBUNTU-CVE-2026-63383

## What is CVE-2026-63383?

CVE-2026-63383 is a high-severity memory corruption vulnerability in libevent, published on 20 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Libevent is an event notification library. Prior to 2.1.13 and 2.2.2-alpha, libevent can read beyond a contiguous evbuffer region in event_tagging.c when decode_tag_internal requests at most five bytes from evbuffer_pullup but iterates using the full logical buffer length. A fragmented evbuffer containing a six-byte malformed tag can therefore advance past the pullup window and trigger an out-of-bounds read, which can crash a process that decodes attacker-controlled tagged RPC data. This issue is fixed in versions 2.1.13 and 2.2.2-alpha.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-63383?


## How do I fix CVE-2026-63383?

Upgrade to a fixed version.

## Is CVE-2026-63383 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63383 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63383 and fix it if it is affected.

What it is: CVE-2026-63383 is a high-severity memory corruption vulnerability in libevent, published on 20 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63383 exists.

Affected product: libevent. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63383/ (Markdown: https://insights.sbomify.com/CVE-2026-63383/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63383
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63383
- OSV: https://osv.dev/vulnerability/CVE-2026-63383

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63383/
Summaries are generated and may contain mistakes; the official description above is the record.
