# CVE-2026-63388: Libevent: Heap out-of-bounds write in bufferevent_socket_set_conn_address_ reachable via AF_UNIX accept

> A heap out-of-bounds write in Libevent allows local attackers to corrupt memory and potentially execute code via AF_UNIX sockets when assertions are disabled.

- **Severity:** High 8.4 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2026
- **Updated:** 21 Aug 2026
- **Also known as:** AZL-96909, AZL-96956, AZL-97518, AZL-97563, BELL-CVE-2026-63388, DEBIAN-CVE-2026-63388, ECHO-1593-1e6c-1ab6, GHSA-cvq5-vrvr-j338, ROOT-OS-DEBIAN-11-CVE-2026-63388, UBUNTU-CVE-2026-63388

## What is CVE-2026-63388?

CVE-2026-63388 is a high-severity memory corruption vulnerability in libevent, published on 20 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Libevent is an event notification library. Prior to 2.1.13 and 2.2.2-alpha, libevent has a heap out-of-bounds write in bufferevent_sock.c when bufferevent_socket_set_conn_address_ copies a kernel-supplied AF_UNIX peer address into bufferevent_private.conn_address. Release builds compiled with NDEBUG disable the EVUTIL_ASSERT length guard, and the evhttp accept path can pass a 110-byte sockaddr from accept() into the 28-byte field. An unauthenticated local peer able to connect to an AF_UNIX listener can overwrite the adjacent dns_request pointer and heap data, causing memory corruption with confidentiality, integrity, and availability impact. This issue is fixed in versions 2.1.13 and 2.2.2-alpha.

Weakness: CWE-787 (Out-of-bounds Write), CWE-617 (Reachable Assertion)

## Which versions are affected by CVE-2026-63388?


## How do I fix CVE-2026-63388?

Upgrade to a fixed version.

## Is CVE-2026-63388 being exploited?

There is no known exploitation of CVE-2026-63388 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63388 and fix it if it is affected.

What it is: CVE-2026-63388 is a high-severity memory corruption vulnerability in libevent, published on 20 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-63388 in the wild and no public exploit code.

Affected product: libevent. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63388/ (Markdown: https://insights.sbomify.com/CVE-2026-63388/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63388
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63388
- OSV: https://osv.dev/vulnerability/CVE-2026-63388

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63388/
Summaries are generated and may contain mistakes; the official description above is the record.
