CVE-2026-6339 Missing request origin validation on burn-on-read reveal endpoint
An authenticated user can force the reveal of burn-on-read messages without recipient consent due to missing origin validation on the reveal endpoint.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-6339?
CVE-2026-6339 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 18 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 11.5.x <= 11.5.1, 11.4.x <= 11.4.3 fail to validate the X-Requested-With header on the burn-on-read reveal endpoint which allows an authenticated channel member to force the reveal of a burn-on-read message without recipient consent via a crafted Markdown image tag.. Mattermost Advisory ID: MMSA-2026-00636
Weakness: CWE-346
Which versions are affected by CVE-2026-6339?
12 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260327001745-7a339a6438f5 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260327001745-7a339a6438f5 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260327001745-7a339a6438f5 |
github.com/mattermost/mattermost/server/v8 Go | From 11.4.0 | 11.4.4 |
github.com/mattermost/mattermost/server/v8 Go | From 11.4.0 | 11.4.4 |
github.com/mattermost/mattermost/server/v8 Go | From 11.5.0 | 11.5.2 |
6 more packages
github.com/mattermost/mattermost/server/v8 Go | From 11.5.0 | 11.5.2 |
github.com/mattermost/mattermost-server Go | All versions | 5.3.2-0.20260327001745-7a339a6438f5 |
github.com/mattermost/mattermost-server Go | All versions | 5.3.2-0.20260327001745-7a339a6438f5 |
github.com/mattermost/mattermost-server Go | From 11.4.0+incompatible | 11.4.4+incompatible, 11.5.2+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-6339?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20260327001745-7a339a6438f5, 11.4.4 or 11.5.2.
Is CVE-2026-6339 being exploited?
There is no known exploitation of CVE-2026-6339 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-xvcx-mgpc-5xh3, GO-2026-5769.