# CVE-2026-63397: remorses/genql code injection

> An authenticated attacker controlling the GraphQL schema can inject arbitrary JavaScript into generated files, leading to code execution when the client is imported.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Jul 2026
- **Updated:** 21 Jul 2026
- **Also known as:** GHSA-w757-xvvv-vgfw

## What is CVE-2026-63397?

CVE-2026-63397 is a high-severity code injection vulnerability in remorses genql, published on 16 Jul 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

remorses/genql before version 6.3.4 allows an authenticated attacker with control of the GraphQL schema that is passed to genql to inject arbitrary JavaScript or TypeScript. The malicious code is injected into the generated schema.ts file and executes when the genql client is bundled and imported.

Weakness: CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-63397?

2 open source packages ship an affected version, including @genql/cli.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@genql/cli` | npm | All versions | 6.3.4 |
| `@genql/cli` | npm | All versions | 6.3.4 |

## How do I fix CVE-2026-63397?

Upgrade @genql/cli to 6.3.4 or later.

## Is CVE-2026-63397 being exploited?

There is no known exploitation of CVE-2026-63397 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63397 and fix it if it is affected.

What it is: CVE-2026-63397 is a high-severity code injection vulnerability in remorses genql, published on 16 Jul 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-63397 in the wild and no public exploit code.

Affected packages and fixed versions:
- @genql/cli (npm): affected all versions; fixed in 6.3.4
- @genql/cli (npm): affected all versions; fixed in 6.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63397/ (Markdown: https://insights.sbomify.com/CVE-2026-63397/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63397
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63397
- OSV: https://osv.dev/vulnerability/CVE-2026-63397

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63397/
Summaries are generated and may contain mistakes; the official description above is the record.
