# CVE-2026-63408: Grav API Plugin: JWT Access Token Accepted via `?token=` URL Query Parameter

> Attackers can steal JWT tokens from logs or history because the Grav API plugin accepts them via URL query parameters, allowing unauthorized API access.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Aug 2026
- **Updated:** 19 Aug 2026

## What is CVE-2026-63408?

CVE-2026-63408 is a high-severity vulnerability in getgrav grav-plugin-api, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Grav API Plugin is a RESTful API for Grav CMS that provides full headless access to your site's content.  Prior to 1.0.0-rc.16, the Grav API plugin JwtAuthenticator::extractBearerToken() accepts a JWT from the token URL query parameter on every /api/v1 route, including state-changing endpoints. Request URLs consequently expose valid access tokens through Apache, proxy, and CDN logs, browser history, and Referer headers, allowing a party with access to those records to reuse the token with the owner's API privileges. This issue is fixed in version 1.0.0-rc.16.

Weakness: CWE-598 (Use of HTTP Request With Sensitive Query String)

## Which versions are affected by CVE-2026-63408?


## How do I fix CVE-2026-63408?

No fix has been published for CVE-2026-63408 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-63408 being exploited?

There is no known exploitation of CVE-2026-63408 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63408 and fix it if it is affected.

What it is: CVE-2026-63408 is a high-severity vulnerability in getgrav grav-plugin-api, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-63408 in the wild and no public exploit code.

Affected product: getgrav grav-plugin-api. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63408/ (Markdown: https://insights.sbomify.com/CVE-2026-63408/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63408
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63408
- OSV: https://osv.dev/vulnerability/CVE-2026-63408

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63408/
Summaries are generated and may contain mistakes; the official description above is the record.
