CVE-2026-63430 ammonia: mXSS in ammonia via MathML `annotation-xml` encoding strip

Medium 6.3 Published Updated

Attackers can execute JavaScript via mutation XSS in ammonia when specific MathML tags are explicitly allowed, requiring an upgrade to secure applications.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-63430?

CVE-2026-63430 is a medium-severity cross-site scripting vulnerability in rust-ammonia ammonia, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

ammonia is a Rust library for repairing and securing untrusted HTML. Prior to 3.3.2, 4.0.2, and 4.1.3, applications that explicitly allow the math tag, annotation-xml, and at least one raw-text HTML element while disallowing the encoding attribute can permit mutation cross-site scripting. ammonia does not correctly implement annotation-xml's encoding-dependent MathML integration-point behavior after attribute filtering removes encoding, so the sanitizer validates a descendant under one namespace interpretation while the browser reparses the output under another. An attacker can use that namespace transition and an allowed raw-text HTML element to execute JavaScript when a user renders the sanitized output. The required tags are not enabled by default, so applications that do not explicitly allow them are not affected. This issue is fixed in versions 3.3.2, 4.0.2, and 4.1.3.

Weakness: CWE-79

Which versions are affected by CVE-2026-63430?

7 open source packages ship an affected version, including ammonia.

PackageAffectedFixed in
ammonia crates.ioAll versions3.3.2
ammonia crates.ioAll versions3.3.2
ammonia crates.ioFrom 0.0.0-03.3.2, 4.0.2, 4.1.3
ammonia crates.ioFrom 4.0.04.0.2
ammonia crates.ioFrom 4.0.04.0.2
ammonia crates.ioFrom 4.1.04.1.3
1 more packages
ammonia crates.ioFrom 4.1.04.1.3

How do I fix CVE-2026-63430?

Upgrade ammonia to a fixed version for your release line: 3.3.2, 4.0.2 or 4.1.3.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-63430 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63430 exists.

Sources

Also known as DEBIAN-CVE-2026-63430, GHSA-9jh8-v38h-cvhr, RUSTSEC-2026-0193, UBUNTU-CVE-2026-63430.

Is CVE-2026-63430 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free