CVE-2026-63443 Coder: Workspace agent API insecure redirect handling allowed cross-agent file read and write
Authenticated users can exploit insecure redirect handling to read, write files, or execute commands on other workspace agents, crossing tenant boundaries.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-63443?
CVE-2026-63443 is a high-severity server-side request forgery vulnerability in coder, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Coder allows organizations to provision remote development environments via Terraform. Prior to 2.29.19, 2.32.9, 2.33.10, and 2.34.4, agentConn.apiClient() follows redirects while its custom transport accepts the host from the redirected request URL when the port is the workspace agent HTTP API port 4. An authenticated user who controls a modified workspace agent and knows another online agent's UUID can derive the victim's tailnet address and redirect control-plane requests to that agent. HTTP 301, 302, and 303 redirects can redirect read requests, while HTTP 307 and 308 preserve replayable write and process-start requests. The redirected workspace agent file APIs can read or write files as the victim workspace user, and affected versions exposing the workspace agent process API can execute commands after a redirected file write, crossing workspace and tenant boundaries. This issue is fixed in versions 2.29.19, 2.32.9, 2.33.10, and 2.34.4.
Which versions are affected by CVE-2026-63443?
10 open source packages ship an affected version, including github.com/coder/coder/v2 and github.com/coder/coder.
| Package | Affected | Fixed in |
|---|---|---|
github.com/coder/coder/v2 Go | From 2.27.0 | 2.29.19, 2.32.9, 2.33.10, 2.34.4 |
github.com/coder/coder/v2 Go | From 2.27.0 | 2.29.19 |
github.com/coder/coder/v2 Go | From 2.27.0 | 2.29.19 |
github.com/coder/coder/v2 Go | From 2.30.0 | 2.32.9 |
github.com/coder/coder/v2 Go | From 2.30.0 | 2.32.9 |
github.com/coder/coder/v2 Go | From 2.33.0 | 2.33.10 |
4 more packages
github.com/coder/coder/v2 Go | From 2.33.0 | 2.33.10 |
github.com/coder/coder/v2 Go | From 2.34.0 | 2.34.4 |
github.com/coder/coder/v2 Go | From 2.34.0 | 2.34.4 |
github.com/coder/coder Go | All versions | None |
How do I fix CVE-2026-63443?
Upgrade github.com/coder/coder/v2 to a fixed version for your release line: 2.29.19, 2.32.9, 2.33.10 or 2.34.4.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-63443 being exploited?
There is no known exploitation of CVE-2026-63443 in the wild and no public exploit code.
Sources
Also known as GHSA-qrwj-vh9x-gw5v, GO-2026-5923.