# CVE-2026-63443: Coder: Workspace agent API insecure redirect handling allowed cross-agent file read and write

> Authenticated users can exploit insecure redirect handling to read, write files, or execute commands on other workspace agents, crossing tenant boundaries.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** GHSA-qrwj-vh9x-gw5v, GO-2026-5923

## What is CVE-2026-63443?

CVE-2026-63443 is a high-severity server-side request forgery vulnerability in coder, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Coder allows organizations to provision remote development environments via Terraform. Prior to 2.29.19, 2.32.9, 2.33.10, and 2.34.4, agentConn.apiClient() follows redirects while its custom transport accepts the host from the redirected request URL when the port is the workspace agent HTTP API port 4. An authenticated user who controls a modified workspace agent and knows another online agent's UUID can derive the victim's tailnet address and redirect control-plane requests to that agent. HTTP 301, 302, and 303 redirects can redirect read requests, while HTTP 307 and 308 preserve replayable write and process-start requests. The redirected workspace agent file APIs can read or write files as the victim workspace user, and affected versions exposing the workspace agent process API can execute commands after a redirected file write, crossing workspace and tenant boundaries. This issue is fixed in versions 2.29.19, 2.32.9, 2.33.10, and 2.34.4.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-63443?

10 open source packages ship an affected version, including github.com/coder/coder/v2 and github.com/coder/coder.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/coder/coder/v2` | Go | From 2.27.0 | 2.29.19, 2.32.9, 2.33.10, 2.34.4 |
| `github.com/coder/coder/v2` | Go | From 2.27.0 | 2.29.19 |
| `github.com/coder/coder/v2` | Go | From 2.27.0 | 2.29.19 |
| `github.com/coder/coder/v2` | Go | From 2.30.0 | 2.32.9 |
| `github.com/coder/coder/v2` | Go | From 2.30.0 | 2.32.9 |
| `github.com/coder/coder/v2` | Go | From 2.33.0 | 2.33.10 |
| `github.com/coder/coder/v2` | Go | From 2.33.0 | 2.33.10 |
| `github.com/coder/coder/v2` | Go | From 2.34.0 | 2.34.4 |
| `github.com/coder/coder/v2` | Go | From 2.34.0 | 2.34.4 |
| `github.com/coder/coder` | Go | All versions | None |

## How do I fix CVE-2026-63443?

Upgrade github.com/coder/coder/v2 to a fixed version for your release line: 2.29.19, 2.32.9, 2.33.10 or 2.34.4.

## Is CVE-2026-63443 being exploited?

There is no known exploitation of CVE-2026-63443 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63443 and fix it if it is affected.

What it is: CVE-2026-63443 is a high-severity server-side request forgery vulnerability in coder, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-63443 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/coder/coder/v2 (Go): affected from 2.27.0; fixed in 2.29.19, 2.32.9, 2.33.10, 2.34.4
- github.com/coder/coder/v2 (Go): affected from 2.27.0; fixed in 2.29.19
- github.com/coder/coder/v2 (Go): affected from 2.27.0; fixed in 2.29.19
- github.com/coder/coder/v2 (Go): affected from 2.30.0; fixed in 2.32.9
- github.com/coder/coder/v2 (Go): affected from 2.30.0; fixed in 2.32.9
- github.com/coder/coder/v2 (Go): affected from 2.33.0; fixed in 2.33.10
- github.com/coder/coder/v2 (Go): affected from 2.33.0; fixed in 2.33.10
- github.com/coder/coder/v2 (Go): affected from 2.34.0; fixed in 2.34.4
- github.com/coder/coder/v2 (Go): affected from 2.34.0; fixed in 2.34.4
- github.com/coder/coder (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63443/ (Markdown: https://insights.sbomify.com/CVE-2026-63443/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63443
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63443
- OSV: https://osv.dev/vulnerability/CVE-2026-63443

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63443/
Summaries are generated and may contain mistakes; the official description above is the record.
