# CVE-2026-6346: Sensitive credentials exposed in plaintext in Mattermost support packets

> Attackers with access to support packets can obtain sensitive credentials in plaintext due to insufficient sanitization of configuration fields.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 May 2026
- **Updated:** 18 May 2026
- **Also known as:** GHSA-9p64-jpc7-m2rp, GO-2026-5293

## What is CVE-2026-6346?

CVE-2026-6346 is a high-severity vulnerability in Mattermost Mattermost Server, published on 18 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13, 11.4.x <= 11.4.3 fail to sanitize sensitive configuration fields before including them in support packet generation, which allows a Mattermost System Admin or any party with access to a support packet to obtain sensitive credentials in plaintext via downloading a support packet from the System Console.. Mattermost Advisory ID: MMSA-2026-00607

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-6346?

14 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20260326202606-fac92f4a71f3 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20260326202606-fac92f4a71f3 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20260326202606-fac92f4a71f3 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.11.0 | 10.11.14 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.11.0 | 10.11.14 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 11.4.0 | 11.4.4 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 11.4.0 | 11.4.4 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 11.5.0 | 11.5.2 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 11.5.0 | 11.5.2 |
| `github.com/mattermost/mattermost-server` | Go | All versions | 5.3.2-0.20260326202606-fac92f4a71f3 |
| `github.com/mattermost/mattermost-server` | Go | All versions | 5.3.2-0.20260326202606-fac92f4a71f3 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0+incompatible | 10.11.14+incompatible, 11.4.4+incompatible, 11.5.2+incompatible |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2026-6346?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20260326202606-fac92f4a71f3, 10.11.14, 11.4.4 or 11.5.2.

## Is CVE-2026-6346 being exploited?

There is no known exploitation of CVE-2026-6346 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6346 and fix it if it is affected.

What it is: CVE-2026-6346 is a high-severity vulnerability in Mattermost Mattermost Server, published on 18 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-6346 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20260326202606-fac92f4a71f3
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20260326202606-fac92f4a71f3
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20260326202606-fac92f4a71f3
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.11.0; fixed in 10.11.14
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.11.0; fixed in 10.11.14
- github.com/mattermost/mattermost/server/v8 (Go): affected from 11.4.0; fixed in 11.4.4
- github.com/mattermost/mattermost/server/v8 (Go): affected from 11.4.0; fixed in 11.4.4
- github.com/mattermost/mattermost/server/v8 (Go): affected from 11.5.0; fixed in 11.5.2
- github.com/mattermost/mattermost/server/v8 (Go): affected from 11.5.0; fixed in 11.5.2
- github.com/mattermost/mattermost-server (Go): affected all versions; fixed in 5.3.2-0.20260326202606-fac92f4a71f3
- github.com/mattermost/mattermost-server (Go): affected all versions; fixed in 5.3.2-0.20260326202606-fac92f4a71f3
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0+incompatible; fixed in 10.11.14+incompatible, 11.4.4+incompatible, 11.5.2+incompatible

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6346/ (Markdown: https://insights.sbomify.com/CVE-2026-6346/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6346
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6346
- OSV: https://osv.dev/vulnerability/CVE-2026-6346

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6346/
Summaries are generated and may contain mistakes; the official description above is the record.
