# CVE-2026-63461: Vendure: Shop API list queries can return non-public entities when filterOperator is OR

> Unauthenticated attackers can retrieve hidden products and private collections by manipulating filter operators in the Shop API.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-xf65-r35x-wmmv

## What is CVE-2026-63461?

CVE-2026-63461 is a medium-severity missing authorization vulnerability in vendurehq vendure, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vendure is an open-source headless commerce platform. Prior to 3.6.5, the public Shop API products, collections, and facets queries combine mandatory visibility guards with caller-supplied filters using the caller-controlled filterOperator. When filterOperator is OR, a predicate matching a hidden entity can bypass the Product.enabled, Collection.isPrivate, or Facet.isPrivate guard. An unauthenticated caller can therefore retrieve disabled products and private collections or facets. This issue is fixed in version 3.6.5.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-63461?

2 open source packages ship an affected version, including @vendure/core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@vendure/core` | npm | From 1.0.0 | 3.6.5 |
| `@vendure/core` | npm | From 1.0.0 | 3.6.5 |

## How do I fix CVE-2026-63461?

Upgrade @vendure/core to 3.6.5 or later.

## Is CVE-2026-63461 being exploited?

There is no known exploitation of CVE-2026-63461 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63461 and fix it if it is affected.

What it is: CVE-2026-63461 is a medium-severity missing authorization vulnerability in vendurehq vendure, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-63461 in the wild and no public exploit code.

Affected packages and fixed versions:
- @vendure/core (npm): affected from 1.0.0; fixed in 3.6.5
- @vendure/core (npm): affected from 1.0.0; fixed in 3.6.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63461/ (Markdown: https://insights.sbomify.com/CVE-2026-63461/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63461
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63461
- OSV: https://osv.dev/vulnerability/CVE-2026-63461

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63461/
Summaries are generated and may contain mistakes; the official description above is the record.
