CVE-2026-63462 Unleash: Unauthenticated single-request DoS via OpenAPI validation error formatter
Unleash allows unauthenticated attackers to crash the Node process via deep JSON nesting in OpenAPI validation, causing service outage.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-63462?
CVE-2026-63462 is a high-severity denial of service vulnerability in unleash, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Unleash is an open-source feature management platform. Prior to 7.5.2, 7.6.5, and 8.0.2, the shared OpenAPI validation error path in src/lib/error/bad-data-error.ts passes a raw request value from lodash.get to JSON.stringify in genericErrorMessage and fromOpenApiValidationErrors without guarding stack exhaustion. An unauthenticated attacker can send a roughly 10 KB JSON value nested thousands of levels deep to POST /edge/validate, POST /edge/issue-token, or another OpenAPI-validated endpoint, causing RangeError: Maximum call stack size exceeded in openAPIValidationMiddleware and terminating the Node process because no uncaughtException handler recovers it. Replaying the request can sustain a complete service outage. This issue is fixed in versions 7.5.2, 7.6.5, and 8.0.2.
Weakness: CWE-674
Which versions are affected by CVE-2026-63462?
6 open source packages ship an affected version, including unleash-server.
| Package | Affected | Fixed in |
|---|---|---|
unleash-server npm | All versions | 7.5.2 |
unleash-server npm | All versions | 7.5.2 |
unleash-server npm | From 7.6.0 | 7.6.5 |
unleash-server npm | From 7.6.0 | 7.6.5 |
unleash-server npm | From 8.0.0 | 8.0.2 |
unleash-server npm | From 8.0.0 | 8.0.2 |
How do I fix CVE-2026-63462?
Upgrade unleash-server to a fixed version for your release line: 7.5.2, 7.6.5 or 8.0.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-63462 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63462 exists.
Sources
Also known as GHSA-r5pq-6chh-j3xp, MINI-j4pp-98gg-q48h.