# CVE-2026-63462: Unleash: Unauthenticated single-request DoS via OpenAPI validation error formatter

> Unleash allows unauthenticated attackers to crash the Node process via deep JSON nesting in OpenAPI validation, causing service outage.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-r5pq-6chh-j3xp, MINI-j4pp-98gg-q48h

## What is CVE-2026-63462?

CVE-2026-63462 is a high-severity denial of service vulnerability in unleash, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Unleash is an open-source feature management platform. Prior to 7.5.2, 7.6.5, and 8.0.2, the shared OpenAPI validation error path in src/lib/error/bad-data-error.ts passes a raw request value from lodash.get to JSON.stringify in genericErrorMessage and fromOpenApiValidationErrors without guarding stack exhaustion. An unauthenticated attacker can send a roughly 10 KB JSON value nested thousands of levels deep to POST /edge/validate, POST /edge/issue-token, or another OpenAPI-validated endpoint, causing RangeError: Maximum call stack size exceeded in openAPIValidationMiddleware and terminating the Node process because no uncaughtException handler recovers it. Replaying the request can sustain a complete service outage. This issue is fixed in versions 7.5.2, 7.6.5, and 8.0.2.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-63462?

6 open source packages ship an affected version, including unleash-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `unleash-server` | npm | All versions | 7.5.2 |
| `unleash-server` | npm | All versions | 7.5.2 |
| `unleash-server` | npm | From 7.6.0 | 7.6.5 |
| `unleash-server` | npm | From 7.6.0 | 7.6.5 |
| `unleash-server` | npm | From 8.0.0 | 8.0.2 |
| `unleash-server` | npm | From 8.0.0 | 8.0.2 |

## How do I fix CVE-2026-63462?

Upgrade unleash-server to a fixed version for your release line: 7.5.2, 7.6.5 or 8.0.2.

## Is CVE-2026-63462 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63462 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-63462 and fix it if it is affected.

What it is: CVE-2026-63462 is a high-severity denial of service vulnerability in unleash, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-63462 exists.

Affected packages and fixed versions:
- unleash-server (npm): affected all versions; fixed in 7.5.2
- unleash-server (npm): affected all versions; fixed in 7.5.2
- unleash-server (npm): affected from 7.6.0; fixed in 7.6.5
- unleash-server (npm): affected from 7.6.0; fixed in 7.6.5
- unleash-server (npm): affected from 8.0.0; fixed in 8.0.2
- unleash-server (npm): affected from 8.0.0; fixed in 8.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-63462/ (Markdown: https://insights.sbomify.com/CVE-2026-63462/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-63462
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-63462
- OSV: https://osv.dev/vulnerability/CVE-2026-63462

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-63462/
Summaries are generated and may contain mistakes; the official description above is the record.
