CVE-2026-6347 Mattermost Calls plugin exposes TURN server credentials in plaintext in support packets
Attackers with access to support packets can obtain plaintext TURN server credentials due to unsanitized plugin configuration exports.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-6347?
CVE-2026-6347 is a high-severity vulnerability in Mattermost Mattermost Server, published on 18 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13, 11.4.x <= 11.4.3 fail to sanitize sensitive configuration fields in the Mattermost Calls plugin which allows an attacker with access to a support packet to obtain TURN server credentials via the plaintext values present in the exported plugin configuration.. Mattermost Advisory ID: MMSA-2026-00605
Weakness: CWE-200
Which versions are affected by CVE-2026-6347?
10 open source packages ship an affected version, including github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-plugin-calls. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.14 |
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.14 |
github.com/mattermost/mattermost-server Go | From 10.11.0+incompatible | 10.11.14+incompatible, 11.4.4+incompatible, 11.5.2+incompatible |
github.com/mattermost/mattermost-server Go | From 11.4.0 | 11.4.4 |
github.com/mattermost/mattermost-server Go | From 11.4.0 | 11.4.4 |
github.com/mattermost/mattermost-server Go | From 11.5.0 | 11.5.2 |
4 more packages
github.com/mattermost/mattermost-server Go | From 11.5.0 | 11.5.2 |
github.com/mattermost/mattermost-plugin-calls Go | All versions | 1.12.0-rc2 |
github.com/mattermost/mattermost-plugin-calls Go | All versions | 1.12.0-rc2 |
github.com/mattermost/mattermost-plugin-calls Go | All versions | 1.12.0-rc2 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-6347?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.14, 10.11.14+incompatible, 11.4.4+incompatible or 11.5.2+incompatible.
Is CVE-2026-6347 being exploited?
There is no known exploitation of CVE-2026-6347 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-82j6-4fq7-fx62, GO-2026-5238.